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Kakinada, 

Date: 20-01-2025. 

 

To, 

Dr. V.Anantha Lakshmi, 

Principal, 

A.S.D. Govt. Degree College for Women (A), 

Kakinada. 

 

 

From, 

N.N.Subrahmanyeswari, 

Incharge of Department of Computer Science, 

A.S.D. Govt. Degree College for Women (A), 

Kakinada. 

 

Sub: Request to conduct the Certificate Course on “Excel Essentials: From Basics to Problem     

 Solving”  for I B.Sc. (Computer Science-Honors) Students from 27-01-2025 to 24-03-2025 -Reg. 

 

Respected Madam, 

 

         The Department of Computer Science wishes to organize the Certificate course on “Excel Essentials: 

From Basic to Problem Solving” with a duration of 45 days from 27-01-2025 to 24-03-2025 for I B.Sc. (computer 

Science-Honors) students. This course aims to make the students get acquainted with the foundation skills and logic 

for communicating with programming languages. Please consider the request to conduct the Certificate course for 

the students. 

  

              Thanking you, Madam. 

 

 

          Yours faithfully, 
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The Department of Computer Science wishes to organize the Certificate Course 

on “Excel Essentials: From Basics to Problem Solving” with the duration from 27-01-

2025 to 24-03-2025 for I B.Sc.(Computer Science-Honors)  students to enhance their 

Computer Skills.  

 

Note:  
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     Course Objectives:  

 To help students to become competent and confident users of Computers. 

 To enable the students utilize the basic knowledge and skills acquired which assists them in their 

daily lives.  

 To prepare students ready for the Digital world. 

  

     Course Outcomes: 

      After the completion of the course, the student will be able to 

         CO1: Acquire the knowledge on basic computer terminology 

         CO2: Efficiently learn and use MS-Excel 

         CO3: Work with MS-Excel and its applications 

         CO4: Format, organize and calculate data in a spreadsheet 

         CO5: Protect data in worksheets and workbooks and create simple PivotTable reports  

 

      Evaluation Process: 

      Assessment will be done based on the Periodical Assignments given during the course and a     

      Final Assessment will be done by conducting a test at the end of the course. 

  

  

  

 

 

 

 



 

Syllabus 
      Module 1 (5 Hours) 

        Fundamentals of Computer: Introduction to Computers, Characteristics of Computers and Limitations of 

Computers, Block Diagram of Computer, Architecture of Computer, Types of Computers, Input and output 

devices, Memories, Types of Memories, Types of Software, Programming Languages and its types, Operating 

Systems and its types. 

Module 2 (10 Hours) 

MS- Excel: Introduction,  Features of Ms-Excel & Parts of MS-Excel window, Entering and editing data in 

worksheet, Workbook – Cell - Parts of a window-Saving, Closing, Opening of a Work Book – Editing – 

Advantages – Create Worksheets and workbooks, Import data from a delimited text file, Add a worksheet 

to an existing workbook, Copy and move a worksheet  

        Module 3 (10 Hours) 

Types of Functions - Formulas and Functions, Formatting options, Data Filtering, Perform Conditional 

Operations by using Functions, Format and Modify Text by using Functions, Summarize Data by using Functions  

       Module 4 (10 Hours) 

 Apply Custom Data Formats and Validation, Apply Advanced Conditional Formatting and Filtering, Create and 

Modify Custom Workbook Elements, Create and modify simple macros, Insert and configure form controls 

Module 5 (10 Hours) 

Create Charts: Create a new chart, Add additional data series, Switch between rows and columns in source data, 

Analyze data by using Quick Analysis, Format Charts, Resize charts, Add and modify chart elements, Apply chart 

layouts and styles, Move charts to a chart sheet. 
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SECTION-A 

I. Answer any TEN of the following questions.                  10 X 2 = 20 

 

1. Define Computer. 

2. List the input devices. 

3. What is the function of CPU? 

4. List the types of memories. 

5. Give the features of MS-Excel.  

6. What are the parts of Excel Worksheet? 

7. What is meant by Cell? 

8. How to copy and move the sheets in Excel Workbook? 

9. What is meant by Filtering? 

10. Define Macro. 

11. How to format the data in Excel Workbook? 

12. List the steps used to create a Chart. 

 

 

SECTION-B 

II. Answer any FOUR questions.                               4 X 5 = 20   

13. Explain about the architecture of a computer with block diagram. 

14. Discuss about types of Computers. 

15. Give the procedure to perform operations on Worksheet in Ms-Excel. 

16. Explain different functions in Ms-Excel. 

17. Discuss about different types of Charts in Excel. 

18. Explain working with Macros. 
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“Excel Essentials: From Basics to Problem Solving” 
 

1.1 Introduction to Computers 

Definition of a Computer: 

A computer is an electronic device that manipulates information, or data. It has the ability to store, retrieve, 

and process data. You may already know that you can use a computer to type documents, send email, play games, 

and browse the Web. You can also use it to edit or create spreadsheets, presentations, and even videos. The basic parts of 

a desktop computer are the computer case, monitor, keyboard, mouse, and power cord. Each part plays an important 

role whenever we use a computer. 

1.2 Characteristics and Limitations of Computer 

Speed 
Speed means the duration computer system requires in fulfilling a task or completing an activity. It is well-known that 

computers need very little time than humans in completing a task. Generally, humans take into account a second or 

minute as a unit of time. 

Accuracy 

Accuracy means the level of precision with which calculations are made and tasks are performed. One may invest years 

of his life in detecting errors in computer calculations or updating a wrong record. 

Reliability 

Reliability is the quality due to which the user can stay dependable on the computer. Computers systems are 

well-adjusted to do repetitive tasks.  

Adaptability 

Adaptability of computer system means the quality of it to complete a different type of tasks: simple as well 

as complex.  

Storage 

Storage is the ability of the computer to store data in itself for accessing it again in future. Nowadays, apart 

from having instantaneous access to data, computers have a huge ability to store data in a little physical 

space. 

1.3 Limitations of Computer Systems 
Limitations are the drawbacks of the computer system in which humans outperform them. 

Lack of common-sense 

This is one of the major limitations of computer systems. No matter how efficient, fast and reliable computer 

systems might be but yet do not have any common sense because no full-proof algorithm has been designed 

to programme logic into them. As computers function based on the stored programme(s), they simply lack  

of the limitations of computer systems is that they have zero Intelligence Quotient (IQ). 

1.4 Block Diagram of a Computer 

 



1.5 Architecture of a Computer 

1. Input: This is the process of entering data and programs in to the computer system. You should know that 

computer is an electronic machine like any other machine which takes as inputs raw data and performs some 

processing giving out processed data. Therefore, the input unit takes data from us to the computer in an 

organized manner for processing.  

2. Storage: The process of saving data and instructions permanently is known as storage. Data has to be fed 

into the system before the actual processing starts. It is because the processing speed of Central Processing 

Unit (CPU) is so fast that the data has to be provided to CPU with the same speed. Therefore the data is first 

stored in the storage unit for faster access and processing. This storage unit or the primary storage of the 

computer system is designed to do the above functionality. It provides space for storing data and instructions.  

The storage unit performs the following major functions:  

All data and instructions are stored here before and after processing.  

• Intermediate results of processing are also stored here.  

Processing: The task of performing operations like arithmetic and logical operations is called processing. 

The Central Processing Unit (CPU) takes data and instructions from the storage unit and makes all sorts of 

calculations based on the instructions given and the type of data provided. It is then sent back to the storage 

unit.  

Control: The manner how instructions are executed and the above operations are performed. Controlling of 

all operations like input, processing and output are performed by control unit. It takes care of step by step 

processing of all operations inside the computer.  Output: This is the process of producing results from the 

data for getting useful information. Similarly the output produced by the computer after processing must also 

be kept somewhere inside the computer before being given to you in human readable form. Again the output 

is also stored inside the computer for further processing.  

Arithmetic Logical Unit (ALU)   

Logical Unit :After you enter data through the input device it is stored in the primary storage unit. The actual 

processing of the data and instruction are performed by Arithmetic Logical Unit. The major operations 

performed by the ALU are addition, subtraction, multiplication, division, logic and comparison. Data is 

transferred to ALU from storage unit when required. After processing the output is returned back to storage 

unit for further processing or getting stored.  

Control Unit (CU)   

The next component of computer is the Control Unit, which acts like the supervisor seeing that things are 

done in proper fashion. Control Unit is responsible  for  co ordinating various operations using time signal. 

The control unit determines the sequence in which computer programs and instructions are executed. Things 

like processing of programs stored in the main memory, interpretation of the instructions and issuing of 

signals for other units of the computer to execute them. It also acts as a switch board operator when several 

users access the computer simultaneously. Thereby it coordinates the activities of computer’s peripheral 

equipment as they perform the input and output.  

Central Processing Unit (CPU)  

The ALU and the CU of a computer system are jointly known as the central processing unit. You may call 

CPU as the brain of any computer system. It is just like brain that takes all major decisions, makes all sorts 

http://ecomputernotes.com/fundamental/introduction-to-computer/control-unit
http://ecomputernotes.com/fundamental/information-technology/what-do-you-mean-by-data-and-information
http://ecomputernotes.com/fundamental/input-output-and-memory/what-is-primary-storage
http://ecomputernotes.com/fundamental/introduction-to-computer/what-is-cpu


of calculations and directs different parts of the computer functions by activating and controlling the 

operations. 

1.6 Types of Computers 

 

Personal Computer: 

A single person defines the personal computer, or PC, as any computer designed for general use by one person. While 

a Mac is a PC, most people relate the term with computers that run the Windows operating system. PCs were first 

known as microcomputers because they were a complete computer but built on a smaller scale than the huge systems 

in use by most businesses. Personal computers come in many forms, including the new Apple iPad. 

 

Desktop PC: 

 that is not designed for portability is a desktop computer. The expectation with desktop systems is that you will set the 

computer up in a permanent location, like a desk or table. Most desktops offer more power, storage and versatility for 

less cost than their portable brethren. 

 

Laptop:  

Also called notebooks, laptops are portable computers that mix the display, keyboard, a pointing device or trackball, 

processor, memory and hard drive all in a battery‐operated package slightly larger than an average hardcover book. On 

the left is a picture of Apple CEO Steve Jobs holding up the MacBook Pro Air. 

 

Tablet Computers: 

Tablet Computers are ultra-‐portable computers that are even smaller than traditional laptops. Their low cost means 

they're cheaper than almost any brand-‐new laptop you'll find at retail outlets. However, the internal components are 

less powerful than those in regular laptops. Recent improvements to tablet computers have allowed users to view HD 

video, get high quality sound, great photo capabilities, and the ability to share information, photos, and videos with 

anyone. 

 

Smart Phones: 

Smart phones are handheld-‐sized computers that often use flash memory instead of a hard drive for storage. These 

devices usually do not have keyboards but rely on touch screen technology for user input. Smart phones are typically 

smaller than a paperback novel, very lightweight with a reasonable battery life. Smartphones have the same capabilities 

as tablet computers, but also allow users to text or make phone calls. 

 

 

Workstation: 

Another type of computer is a workstation. A workstation is simply a desktop computer that has a more powerful 

processor, additional memory and enhanced capabilities for performing a special group of task, such as 3D Graphics 

or game development. They may even use multiple screens to enhance their viewing.  

 

Server: 

A computer that has been optimized to provide services to other computers over a network. Servers usually have 

powerful processors, lots of memory and large hard drives. Servers allow many computers to share a printer or other 

devices without the cost of having to buy one for every computer. Servers also allow users to share information and 

files with each other. The computers in this lab are part of a network. 

 

Mainframe: 

In the early days of computing, mainframes were huge computers that could fill an entire room or even a whole floor! 

As the size of computers has diminished while the power has increased, the term mainframe has fallen out of use in 

favor of enterprise server. You'll still hear the term used, particularly in large companies to describe the huge machines 

processing millions of transactions every day. Mainframes store vast amounts of information. 



 

Super Computer: 

This type of computer usually costs hundreds of thousands or even millions of dollars. Although some 

supercomputers are single computer systems, most are composed of multiple high performance computers 

working in parallel as a single system. Super computers are the fastest, most powerful, most expensive 

computers made today. The best-‐known supercomputers are built by Cray Super computers. Many of 

today’s great movies use supercomputers for their CGI. They can perform over a trillion calculations per 

second. 

 

Wearable Computers: 

The latest trend in computing is wearable computers. Essentially, common computer applications (e-‐mail, 

database, multimedia, calendar/scheduler) are integrated into watches, cell phones, visors and even clothing. 

Users can use these devices for health and fitness, navigation, social networking, and gaming. Google can 

now augment a person’s vision through special computer glasses. The glasses can stream information to the 

lenses and allow the wearer to send and receive messages through voice commands.  

 1.7 Input and Output Devices: 

Hardware 

Hardware refers to the physical elements of a computer. This is also sometime called the machinery or the 

equipment of the computer. Examples of hardware in a computer are the keyboard, the monitor, the mouse and 

the central processing unit. However, most of a computer's hardware cannot be seen; in other words, it is not an 

external element of the computer, but rather an internal one, surrounded by the computer's casing (tower). A 

computer's hardware is comprised of many different parts, but perhaps the most important of these is 

the motherboard. The motherboard is made up of even more parts that power and control the computer. 

 

Software: 

Software, commonly known as programs or apps, consists of all the instructions that tell the hardware how to 

perform a task. These instructions come from a software developer in the form that will be accepted by 

the platform (operating system + CPU) that they are based on. For example, a program that is designed for the 

Windows operating system will only work for that specific operating system. Compatibility of software will vary 

as the design of the software and the operating system differ. Software that is designed for Windows XP may 

experience a compatibility issue when running under Windows 2000 or NT. 

 

Computer case 

 
The computer case is the metal and plastic box that contains the main components of the computer, including the 

motherboard, central processing unit (CPU), and power supply. The front of the case usually has an On/Off 

button and one or more optical drives. Computer cases come in different shapes and sizes. A desktop case lies flat 

on a desk, and the monitor usually sits on top of it. A tower case is tall and sits next to the monitor or on the floor. All-

in-one computers come with the internal components built into the monitor, which eliminates the need for a separate 

case. 

Monitor 

http://www.webopedia.com/TERM/H/hardware.html
http://www.webopedia.com/TERM/S/software.html


The monitor works with a video card, located inside the computer case, to display images and text on the screen. 

Most monitors have control buttons that allow you to change your monitor's display settings, and some monitors also 

have built-in speakers. 

Newer monitors usually have LCD (liquid crystal display) or LED (light-emitting diode) displays. These can be made 

very thin, and they are often called flat-panel displays. Older monitors use CRT (cathode ray tube) displays. CRT 

monitors are much larger and heavier, and they take up more desk space. 

Keyboard 

The keyboard is one of the main ways to communicate with a computer. There are many different types of keyboards, 

but most are very similar and allow you to accomplish the same basic tasks. Click the buttons in the interactive below 

to learn about the different parts of the keyboard. 

 
Mouse 

The mouse is another important tool for communicating with computers. Commonly known as a pointing device, it 

lets you point to objects on the screen, click on them, and move them. 

There are two main mouse types: optical and mechanical. The optical mouse uses an electronic eye to detect movement 

and is easier to clean. The mechanical mouse uses a rolling ball to detect movement and requires regular cleaning to 

work properly. 

To learn the basics of using a mouse, check out our interactive Mouse Tutorial. 

Mouse alternatives: 

There are other devices that can do the same thing as a mouse. Many people find them easier to use, and they also 

require less desk space than a traditional mouse. The most common mouse alternatives are below. 

 Trackball: A trackball has a ball that can rotate freely. Instead of moving the device like a mouse, you 

can roll the ball with your thumb to move the pointer. 

 
 Touchpad: A touchpad—also called a trackpad—is a touch-sensitive pad that lets you control the 

pointer by making a drawing motion with your finger. Touch pads are common on laptop computers. 

 

 

Front of a computer case: 

Click the buttons in the interactive below to become familiar with the front of a computer. 

 

http://www.gcflearnfree.org/mousetutorial/


Back of a computer case 

The back of a computer case has connection ports that are made to fit specific devices. The placement will vary from 

computer to computer, and many companies have their own special connectors for specific devices. Some of the ports 

may be color coded to help you determine which port is used with a particular device. 

Click the buttons in the interactive below to become familiar with the back of a computer. 

 
 

Peripherals used with computer: 

The most basic computer setup usually includes the computer case, monitor, keyboard, and mouse, but 

you can plug many different types of devices into the extra ports on your computer. These devices are 

called peripherals. Let's take a look at some of the most common ones. 

Printers: A printer is used to print documents, photos, and anything else that appears on your screen. There are 

many types of printers, including inkjet, laser, and photo printers. There are even all-in-one printers, which can 

also scan and copy documents. 

 
Scanners: A scanner allows you to copy a physical image or document and save it to your computer as a digital 

(computer-readable) image. Many scanners are included as part of an all-in-one printer, although you can also 

buy a separate flatbed or handheld scanner. 

Speakers/headphones: Speakers and headphones are output devices, which means they send information from 

the computer to the user—in this case, they allow you to hear sound and music. Depending on the model, they 

may connect to the audio port or the USB port. Some monitors also have built-in speakers. 

 
Microphones: A microphone is a type of input device, or a device that receives information from a user. You can 

connect a microphone to record sound or talk with someone else over the Internet. Many laptop computers come 

with built-in microphones. 

Web cameras: A web camera—or webcam—is a type of input device that can record videos and take pictures. It 

can also transmit video over the Internet in real time, which allows for video chat or video conferencingwith someone 

else. Many webcams also include a microphone for this reason. 

 
Game controllers and joysticks: A game controller is used to control computer games. There are many other types of 

controllers you can use, including joysticks, although you can also use your mouse and keyboard to control most 

games. 

 



Digital cameras: A digital camera lets you capture pictures and videos in a digital format. By connecting the camera 

to your computer's USB port, you can transfer the images from the camera to the computer. 

 

Mobile phones, MP3 players, tablet computers, and other devices: Whenever you buy an electronic device, such 

as a mobile phone or MP3 player, check to see if it comes with a USB cable. If it does, this means you can most likely 

connect it to your computer. 

 

Inside a computer 

Motherboard 

The motherboard is the computer's main circuit board. It's a thin plate that holds the CPU, memory, connectors for 

the hard drive and optical drives, expansion cards to control the video and audio, and connections to your computer's 

ports (such as USB ports). The motherboard connects directly or indirectly to every part of the computer. 

CPU/processor 

The central processing unit (CPU), also called a processor, is located inside the computer case on the motherboard. 

It is sometimes called the brain of the computer, and its job is to carry out commands. Whenever you press a key, click 

the mouse, or start an application, you're sending instructions to the CPU. 

The CPU is usually a two-inch ceramic square with a silicon chip located inside. The chip is usually about the size 

of a thumbnail. The CPU fits into the motherboard's CPU socket, which is covered by the heat sink, an object that 

absorbs heat from the CPU. 

A processor's speed is measured in megahertz (MHz), or millions of instructions per second; and gigahertz (GHz), 

or billions of instructions per second. A faster processor can execute instructions more quickly. However, the actual 

speed of the computer depends on the speed of many different components—not just the processor. 

1.8 Memories 

RAM (random access memory) 

 

RAM is your system's short-term memory. Whenever your computer performs calculations, it temporarily 

stores the data in the RAM until it is needed. 

This short-term memory disappears when the computer is turned off. If you're working on a document, spreadsheet, 

or other type of file, you'll need to save it to avoid losing it. When you save a file, the data is written to the hard drive, 

which acts as long-term storage. 

RAM is measured in megabytes (MB) or gigabytes (GB). The more RAM you have, the more things your computer 

can do at the same time. If you don't have enough RAM, you may notice that your computer is sluggish when you have 

several programs open. Because of this, many people add extra RAM to their computers to improve performance. 

Hard disk 

 

 

 

 

 

 

 

The hard drive is where your software, documents, and other files are stored. The hard drive is long-term storage, 

which means the data is still saved even if you turn the computer off or unplug it. 

 



When you run a program or open a file, the computer copies some of the data from the hard drive onto the RAM. 

When you save a file, the data is copied back to the hard drive. The faster the hard drive, the faster your computer 

can start up and load programs. 

Expansion cards 
Most computers have expansion slots on the motherboard that allow you to add various types of expansion cards. 

These are sometimes called PCI (peripheral component interconnect) cards. You may never need to add any PCI 

cards because most motherboards have built-in video, sound, network, and other capabilities. 

 

However, if you want to boost the performance of your computer or update the capabilities of an older computer, you 

can always add one or more cards. Below are some of the most common types of expansion cards. 

Video card 

 
The video card is responsible for what you see on the monitor. Most computers have a GPU (graphics processing 

unit) built into the motherboard instead of having a separate video card. If you like playing graphics-intensive games, 

you can add a faster video card to one of the expansion slots to get better performance. 

 

1.9 Types of Software: 

System Software 

System software is computer software designed to operate the computer hardware to provide basic functionality and 

to provide a platform for running application software. It refers to the operating system and all utility programs that 

manage computer resources at a low-level. 

Programming Software 

Programming software include tools in the form of programs or applications that software developers use to create, 

debug, maintain, or otherwise support other programs and applications. The term usually refers to relatively simple 

programs such as compilers, debuggers, interpreters, linkers, and text editors. 

Application Software  

A program or group of programs designed for end users. Allows end users to accomplish one or more specific (non - 

computer related) tasks. 

1.10 Operating System and Types of Operating System: 

Operating Systems can be categorized according to different criteria like whether an operating system is for mobile 

devices (examples Android and iOS) or desktop (examples Windows and Linux). In this article, we are going to classify 

based on functionalities an operating system provides. 

Types of Operating Systems 

 Batch Operating System: A Batch Operating System is a type of operating system that does not interact with 

the computer directly. There is an operator who takes similar jobs having the same requirements and groups 

them into batches. 

 Time-sharing Operating System: Time-sharing Operating System is a type of operating system that allows 

many users to share computer resources (maximum utilization of the resources). 

 Distributed Operating System: Distributed Operating System is a type of operating system that manages a 

group of different computers and makes appear to be a single computer. These operating systems are designed 

to operate on a network of computers. They allow multiple users to access shared resources and communicate 

with each other over the network. Examples include Microsoft Windows Server and various distributions of 

Linux designed for servers. 

https://www.geeksforgeeks.org/batch-processing-operating-system/
https://www.geeksforgeeks.org/time-sharing-operating-system/
https://www.geeksforgeeks.org/what-is-a-distributed-system/


 Network Operating System: Network Operating System is a type of operating system that runs on a server 

and provides the capability to manage data, users, groups, security, applications, and other networking 

functions. 

 Real-time Operating System: Real-time Operating System is a type of operating system that serves a real-

time system and the time interval required to process and respond to inputs is very small. These operating 

systems are designed to respond to events in real time. They are used in applications that require quick and 

deterministic responses, such as embedded systems, industrial control systems, and robotics. 

 Multiprocessing Operating System: Multiprocessor Operating Systems are used in operating systems to 

boost the performance of multiple CPUs within a single computer system. Multiple CPUs are linked together 

so that a job can be divided and executed more quickly. 

 Single-User Operating Systems: Single-User Operating Systems are designed to support a single user at a 

time. Examples include Microsoft Windows for personal computers and Apple macOS. 

 Multi-User Operating Systems: Multi-User Operating Systems are designed to support multiple users 

simultaneously. Examples include Linux and Unix. 

 Embedded Operating Systems: Embedded Operating Systems are designed to run on devices with limited 

resources, such as smartphones, wearable devices, and household appliances. Examples include Google’s 

Android and Apple’s iOS. 

 Cluster Operating Systems: Cluster Operating Systems are designed to run on a group of computers, or a 

cluster, to work together as a single system. They are used for high-performance computing and for 

applications that require high availability and reliability. Examples include Rocks Cluster Distribution and 

OpenMPI. 

2. MICROSOFT EXCEL 

2.1 Introduction to Excel 

Microsoft Excel is one of the most popular spreadsheet applications that helps you manage data, create 

visually persuasive charts, and thought-provoking graphs. Excel is supported by both Mac and PC 

platforms. Microsoft Excel can also be used to balance a checkbook, create an expense report, build 

formulas, and edit them. Opening Microsoft Excel To begin Microsoft Excel, Go to Applications > 

Microsoft Excel. When opened a Dialogue box on the screen, showing you a few templates and blank 

excel  sheets , if this does not happen click File > New Workbook 

 

Saving Your Document: Computers crash, and documents are lost all the time, so it is best to save 

often. Saving Initially Before you begin you should save your document. To do this, go to File > Save 

As. Microsoft Excel will open a dialog box where you can specify the new file’s name , location of 

where you want it saved, and format of the document. Once you have specified a name, place, and 

format for your new file, press the Save button.  

Saving Later: After you have initially saved your blank document under a new name, you can begin 

your project. However, you will still want to periodically save your work as insurance against a 

computer freeze or a power outage. To save, click File > Save  

 

2.2 Features of MS-Excel & Parts of MS-Excel window 
1. Painless file sharing option 

2. Integrated data model support 

3. Complete cloud file support 

4. Office Add-ins 

5. Recommended charts 

6. Recommended Pivot Tables 

7. Quick Analysis tools 

8. Pivot table filtering with slicers and timelines 

9. Six new functions 

https://www.geeksforgeeks.org/what-is-a-network-operating-system/
https://www.geeksforgeeks.org/real-time-operating-system-rtos/
https://www.geeksforgeeks.org/introduction-of-multiprocessor-and-multicomputer/
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10. Two new data types 

1. Graphical Features of Excel 

Excel offers a lot of graphical features for presenting data in graphs and pictures: 

o Charts: Charts can be used to represent the data in richly detailed graphical format. 

o SmartArts: We can utilize SmartArts to express information by aligning data in creative ways 

graphically. 

o Clip Arts: We can include ready-to-use clip arts to convey our message in a visual format. 

o Shapes: We can use a variety of shapes to depict data in infographics and shapes. With the help of the 

free form features we can draw any shape. 

o Pictures: Any image can be inserted to enhance the objects. For example, backgrounds of 

Worksheets, shapes, and charts. 

2. Functional Features of Excel 

Excel Tools and Features assist us in performing complex calculations and enhancing the Excel application's 

features. 

o Functions: - In Excel Cells, more than 300 built-in formulas are available (Text, Date, Maths, String, 

etc.), which may be used to execute multiple computations. 

o Hyperlinks: - We use hyperlinks in Excel to navigate the different parts of the workbook fast. 

o Spellcheck: - We can avoid grammatical and spelling errors in the data by using the built-in spell 

check feature. 

o Add-ins: - We may develop Excel Add-ins using VBA or.NET to progress the functionality of the 

spreadsheet. 

 VBA Macros: - VBA programming is included in Excel. The Macros Functionality can be used to automate 

repetitive operations. 

 Protection: - Workbook, Worksheet, and VBA Protection options are available in Excel. 

 Conditional Format: - We can format the data based on the specific criteria. This aids in highlighting the 

crucial data range. 

 Excel offers a wide range of add-ins for data analysis and ETL. 

 Database Feature of Excel 

 Excel may be used to create databases and carry out a variety of data processing operations. 

 PivotTables: Summarize data can be used to create an effective cross table. 

 Tables: We can group the rows and columns using parent and child records. This will make it easier to conduct 

additional research rapidly. 

 Grouping: With parent and child records, we can group the rows and columns. 

 Sorting: In Excel, we can sort the data. We can sort the data in Ascending or Descending order with one or 

more than one column. 

 Filtering: The data can be filtered in Excel. In order to filter with essential options, we can set a verity of the 

option. In Excel, there is an option of Advanced Filtering, which allows us to perform more complex filters. 

 Sparklines: Excel 2010 introduced the ability to insert light- weight charts into cells. 

 Database: To install 1 million records, we can utilize Excel as a database. We have the ability to connect to a 

variety of databases and import data into Excel. 

 Data Validations: We can use the Data validation functionality to restrict the types of data that can be entered 

into a cell. We can also provide a drop-down menu where we can choose from a pre-defined list of options. 

 Slicers: - In Excel 2010, Slicers were added, which allow us to connect several pivot tables and filter data 

using buttons. 

 Parts of a Excel Worksheet: 
Some parts of the Excel window (such as Ribbon and scroll bars) are standard in most other Microsoft programs. 

However, other features are more specific to spreadsheets, like the formula bar, worksheet tabs, and name box. 



 
 

The following are the basic parts of the Microsoft Excel Window: 

 

The following are the basic parts of the Microsoft Excel Window: 

 Quick Access Toolbar 

 File Tab 

 Title Bar 

 Control Buttons 

 Menu Bar 

 Ribbon/Toolbar 

 Dialog Box Launcher 

 Name Box 

 Formula Bar 

 Scroll Bars 

 Spreadsheet Area 

 Leaf Bar 

 Column Bar 

 Row Bar Cells 

 Cells 

 Status Bar 

 View Buttons 

 Zoom control 

 

Copy and move the sheets in Excel workbook. 
 Step 1: First, right-click on the sheet tab. Next, click on the Move or Copy option from the drop-down 

list. 

 Step 2: The Move or Copy dialog box opens. 

 Step 3: Under Before Sheet section, select (move to end) option to copy or move the sheet (Data 1) at 

the end. 

Next, select Create a copy and click OK. 



 

Filtering in Excel: 
A filter in Excel is a function that allows you to sort data within a file. A filter takes the data from a range of 

cells and outputs an array of data that matches the applied filter. Filters are an automated process that can refine 

a list, table or spreadsheet based on single or multiple criteria. 

The Filter button is located in the ribbon. You can find the Filter command – 

 
 

2.3 Entering and editing data in worksheet 
On the active worksheet, select the cell or range in which you want to edit existing or enter new data. In the 

active cell, type new data or edit the existing data, and then press Enter or Tab to move the selection to the next 

cell. The changes are applied to all the worksheets that you selected. 

2.4 Workbook – Cell - Parts of a window-Saving 
 Workbook:  A workbook is an Excel file that contains one or more worksheets where you can enter and store data. 

Each worksheet in a workbook is composed of a large number of cells that can hold data you can organize accordingly. 

Microsoft Excel allows you to create a new workbook from a blank workbook or a template. 

Cell: A cell is an essential part of MS-Excel. It is an object of Excel worksheets. Whenever you open Excel, the Excel 

worksheet contains cells to store the information in them. You enter content and your data into these cells. Cells are 

the building blocks of the Excel worksheet. So, you should know every single point about it. 

 

In the Excel worksheet, a cell is a rectangular-shaped box. It is a small unit of the Excel spreadsheet. There are around 

17 billion cells in an Excel worksheet, which are united together in horizontal and vertical lines. 

An Excel worksheet contains cells in rows and columns. Rows are labeled as numbers and columns as alphabets. It 

means the rows are identified by numbers and columns by alphabets. 

 

Save a Workbook :  

Once you’ve created a new workbook, you’ll need to save it if you want to use it again. 

Click the Save button. 



Press Ctrl + S to quickly save a workbook. 

If this is the first time you’ve saved the workbook, the Save As screen will appear. 

Choose where you want to save your file: 

OneDrive: Save to Microsoft’s cloud-based storage so you can open the worksheet on    another computer. 

SharePoint: Save the workbook to a connected SharePoint server. 

This PC: Save to the local storage on your computer. 

Browse: Opens a dialog box, where you can browse through your computer’s folders, drives, and network 

shares. Enter a file name. Click Save. 

2.5 Closing:  
If you click the Close button on the title bar when you have only one Excel file open, the workbook will close and you 

will exit the Excel program. 

Click the Close button. 

2.6 Opening of a Work Book – Editing – Advantages – Create Worksheets and workbooks 

Open: You can locate a workbook on your computer and simply double-click it to open it, but you can also open a 

workbook from within the Excel program. 

Click the File tab. 

Click Open. 

Press Ctrl + O to quickly display the Open tab of the Backstage view. 

Select the location where the file is saved. 

You can choose from: 

Recent: Recent files you've worked on. 

Shared with Me: Files others have shared with you on OneDrive or SharePoint Online. 

OneDrive: Microsoft's cloud-based storage. 

This PC: Browse files on your local computer. 

Browse: Opens a dialog box where you can browse through your computer's folders, drives, and network 

shares. 

1. Select the file you want to open. 

2. Click Open. 

Editing:  
Data that has been entered in a cell can be changed by double clicking the cell location or using the Formula Bar. You 

may have noticed that as you were typing data into a cell location, the data you typed appeared in the Formula Bar. 

The Formula Bar can be used for entering data into cells as well as for editing data that already exists in a cell. The 

following steps provide an example of entering and then editing data that has been entered into a cell location: 

1. Click cell A15 in the Sheet1 worksheet. 

2. Type the abbreviation Tot and press the ENTER key. 

3. Click cell A15. 

4. Move the mouse pointer up to the Formula Bar. You will see the pointer turn into a cursor. Move the cursor to the 

end of the abbreviation Tot and left click. 

5. Type the letters al to complete the word Total. 

6. Click the checkmark to the left of the Formula Bar (see Figure 1.17). This will enter the change into the cell. 

7. Double click cell A15. 

8. Add a space after the word Total and type the word Sales. 

9. Press the ENTER key. 

Advantages of MS Excel 

Because it is simple to preserve data and add and remove information both easily and quickly, MS Excel is used for a 

variety of functions. 

Using MS Excel has several significant benefits, including: 



      1.Easy data input: MS Excel is frequently used for data entry or analysis since there is no limit to the quantity of 

information that can be saved in a spreadsheet, making it simple to enter as much data as you wish. Is. In Excel, filtering 

data is simple and highly useful. 

     2. Data retrieval is easier: Finding information printed on paper may take longer; however, this is not the case 

with an Excel spreadsheet. Data can be located and retrieved with ease. 

    3.Mathematical formulae that are Simple to Use: MS Excel's formula feature has made calculations simpler and 

faster. 

    4. More reliable: These spreadsheets, which may be password-protected on a laptop or desktop computer, are 

significantly less likely to be lost than records or pieces of paper with data that have been written down. 

    5. One location for all data: When the paperwork was completed in the past, data was housed in separate files and 

registers. Now that several worksheets may be added to a single MS Excel file, it has become more practical. 

Create a Worksheet in Excel 
MS Excel or Microsoft Excel is one of Microsoft's most powerful spreadsheet software. It comes with a distinct range 

of built-in features and functions to help us record large amounts of data in a worksheet. By default, whenever we 

create a new workbook in Excel, we get three worksheets, namely Sheet 1, Sheet 2, and Sheet 3. However, there may 

be cases when we may need one or more additional worksheets to record our data. Excel also provides such a useful 

option or feature to the users. 

This article discusses various step-by-step tutorials on creating a worksheet in Excel. Before discussing the process of 

creating a worksheet in Excel, let us briefly discuss the Introduction to Excel worksheet. 

Creating a new Workbook 

Follow these steps to create a new Blank workbook, giving a name to it & saving it: 

Step 1: Click on the Microsoft Office button on the top-left corner. 

Step 2: Then click on New. 

Step 3: A dialog box for New Workbook will pop up. Click on blank Document & then on Create tab. 

A new blank workbook is created & it appears on your screen. 

Note: MS Excel automatically opens a new Workbook for you when you open Excel in your system. 

 

2.6 Import data from a delimited text file: 

1. Choose “Open” from Microsoft Excel’s File menu, and navigate to the folder that contains your 

delimited file. Make sure that you have chosen the option to view all file types. If you don’t do this, you 

will not be able to see your file in the folder. Double-click on the file name to open it. Excel will 

automatically enter “Text Import Wizard” mode. 

2. Choose “Delimited” as the file type that best describes your data on the first screen of the Text Import 

Wizard. Then click “Next” to go to the next screen. 

3. Select the delimiter that is used in your delimited file. If you didn’t know what the delimiter was before 

beginning the file import, you can usually scan the data and determine which character is being used. In our 

example, the file is comma-delimited. After selecting the delimiter, click “Next” to proceed. 

 2.7 Add a worksheet to an existing workbook:   
select that worksheet and then, on the Home tab, in the Cells group, click Insert, and then click Insert Sheet. Tip: You 

can also right-click the tab of an existing worksheet, and then click Insert. On the General tab, click Worksheet, and 

then click OK. 

2.8 Copy and move a worksheet  

Move a worksheet within a workbook 

Select the worksheet tab, and drag it to where you want it.Caution: When you move a sheet to another 

workbook, check any formulas or charts that refer to data on the sheet because moving the sheet might 

cause errors or produce unintended results in your data. Similarly, if you move a sheet that is referred to by 

3-D references, the calculation might include or leave out data on the sheet. 



Copy a worksheet in the same workbook 

1. Press CTRL and drag the worksheet tab to the tab location you want. (or) 

2. Right click on the worksheet tab and select Move or Copy. 

3. Select the Create a copy checkbox. 

4. Under Before sheet, select where you want to place the copy. 

5. Select OK. 

2.9 Types of Functions - Formulas and Functions 

Formulas and Functions 

The Formula Bar is used for you can enter or edit data, a formula or a function that will appear in a specific 

cell. In the image below, cell C1 is selected and 1984 is entered into the formula bar. Note how the data 

appears in both the formula bar and in cell C1. Cells can contain formulas and functions that calculate cell 

values. In our example, SUM(B4:B7) adds the value of each cell in cell range B4:B7and displays the total in 

cell B8. 

  Formatting Attributes Cells can contain formatting attributes that change the way letters, numbers, and dates 

are displayed. For example, percentages can appear as 0.15 or 15%. You can even change a cell's background 

color. Formulas and Functions Cells can contain formulas and functions that calculate cell values. In our 

example, SUM(B4:B7) adds the value of each cell in cell range B4:B7and displays the total in cell B8.To 

insert content1.Click a cell to select it.2.Type content into the selected cell, then press Enter on your 

keyboard. The content will appear in the cell and the formula bar. You can also input and edit cell content in 

the formula bar. Content appears in cell and formula bar.  

  To delete cell content1.Select the cell with content you wish to delete.2.Press the Delete or Backspace key on your 

keyboard. The cell's contents will be deleted. To delete cells: There is an important difference between deleting the 

content of a cell and deleting the cell itself. If you delete the entire cell, the cells below it will shift-up and replace the 

deleted cells. 

  1. Select the cell(s)you wish to delete. 

  2. Select the Delete command from the Home-tab on the Ribbon.  

  3. The cells below will shift up. 

 

2.10 Formatting options 
All cell content uses the same formatting by default, which can make it difficult to read a workbook with a lot of 

information. Basic formatting can customize the look and feel of your workbook, allowing you to draw attention to 

specific sections and making your content easier to view and understand. You can also apply number formatting to tell 

Excel exactly what type of data you’re using in the workbook, such as percentages (%), currency ($), and so on.  

Font Formatting 

To change the font By default, the font of each new workbook is set to Calibri. However, Excel provides a variety of 

other fonts you can use to customize your cell text. In the example below, we'll format our title cell to help distinguish 

it from the rest of the worksheet. 

1. Select the cell(s)you wish to modify.  

2. Click the drop-down arrow next to the Font command on the Home tab. The Font drop-down menu will appear.  

3. Select the desired font. A live preview of the new font will appear as you hover the mouse over different options. 

4. The text will change to the selected font.  

To change the font color 

1. Select the cell(s) you wish to modify. 

2. Click the drop-down arrow next to the Font Color command on the Home tab. The Color menu will 

appear. 

3. Select the desired font color. A live preview of the new font color will appear as you hover the 

mouse over different options. 

 



Formatting the Spreadsheet: 

The default page view for Microsoft Excel spreadsheets display all gridlines and open up in portrait 

orientation. To change the gridlines look at the fifth tab on the Formatting Palette, under Sheet uncheck 

the view box. This will eliminate any gridlines from the spreadsheet. To change the page orientation 

look at the fifth tab on the Formatting Palette, under Orientation and check Landscape. 

Excel. Cells hold all of the data that is being used to create the spreadsheet or workbook. To enter data 

into a cell you simply click once inside of the desired cell, a green border will appear around the cell. 

Cut, Copy, and Paste. You can use the Cut, Copy and Paste features of Excel to change the data within 

your spreadsheet, to move data from other spreadsheets into new spreadsheets, and to save yourself 

the time of re-entering information in a spreadsheet. Cut will actually remove the selection from the 

original location and allow it to be placed somewhere else. Copy allows you to leave the original 

selection where it is and insert a copy elsewhere. Paste is used to insert data that has been cut or copied. 

To Cut or Copy: Highlight the data or text by selecting the cells that they are held within. Go to Edit 

> Copy (Command-X) or Edit > Cut (Command-C).Click the location where the information should 

be placed. Go to Edit > Paste (Command-V). 

 

Formatting Cells 

There are various different options that can be changed to format the spreadsheets cells differently. 

When changing the format within cells you must select the cells that you wish to format. To get to the 

Format Cells dialog box select the cells you wish to change then go to Format > Cells. A box will 

appear on the screen with six different tab options (Number: Allows you to change the measurement 

in which your data is used. (If your data is concerned with money the number that you would use is 

currency)Alignment: This allows you to change the horizontal and vertical alignment of your text 

within each cell. You can also change the orientation of the text within the cells and the control of the 

text within the cells as well. Font: Gives the option to change the size, style, color, and effects. Border: 

Gives the option to change the design of the border around or through the cells. Formatting Rows and 

Columns When formatting rows and columns you can change the height, choose for your information 

to autofit to the cells, hide information within a row or column, un-hide the information. To format a 

row or column go to Format > Row (or Column), or Home tab then format button for PC, then choose 

which option you are going to use. The cell or cells that are going to be formatted need to be selected 

before doing this. Adding Rows and Columns When adding a row or column you are inserting a blank 

row or column next to your already entered data. Before you can add a Row you are going to have to 

select the row that your wish for your new row to be placed in its place. (Rows are on the left hand 

side of the spreadsheet) once the row is selected it is going to highlight the entire row that you chose. 

To insert the row you have to go to Insert > Row. The row will automatically be placed on the 

spreadsheet and any data that was selected in the original row will be moved down below the new row. 

Another way is using the Insert in the Formatting Pallete. 

2.11 Data Filtering : A filter in Excel is a function that allows you to sort data within a file. A filter 

takes the data from a range of cells and outputs an array of data that matches the applied filter. Filters 

are an automated process that can refine a list, table or spreadsheet based on single or multiple criteria. 

2.12 Perform Conditional Operations by using Functions: 

Conditional functions perform calculations on a cell or range of cells only if those cells meet a certain 

condition. These functions test a given range and determine if the condition is true or false before 

continuing. A condition can be any relational comparison: 

Examples: 

 A3>14 Whether the valueof cell A3 is larger than the number 14 

 D5<=2 Whether the value of cell D5 isless than or equal to the number 2 



 T47=”cheese” Whether the value of cell T47 is “cheese” 

There are six types of conditional functions covered by this course. Each has a specific use and 

syntax. 

IF = if(condition,value_if_true,value_if_false) 

If the given condition is true, the cell will be set to the “value_if_true.” If the condition is false, the 

cell will be set to the “value_if_false.” The “value_if_true” and “value_if_false” are optional inputs 

which default to TRUE and FALSE, respectively. 

Example: 

=if(A2>3,32,”Number too small”) 

Reads: If A2>3 is true, then set the cell to 32. Otherwise, set the cell to “Number too small” 

Nested IF Functions 

You can nest one “if” function inside of another to test for multiple conditions at once. A single “if” 

function, without the use of any other functions, can only test for a single condition. 

Example: 

Test the condition of whether the contents of cell A2 are between 10 and 20. 

=if (A2>20,”Number too large”, if (A2<10,”Number too small”, “Just right!”)) 

The completed function will test whether the value of A2 is larger than 20. If it is, the active cell will 

be set to “Number too large.” If A2 is less than 20, it will be tested to see if the value of A2 is less than 

10. If it is, the active cell is set to “Number too small.” Otherwise, we know that the value of A2 must 

be between 10 and 20, so the active cell is set to “Just right!” 

COUNTIF 

=countif(range,criteria) 

The “countif” function will increment the active cell by one each time the criteria is true for a cell in 

the given range. 

Example: 

You want to know how many universities have “red” as one of their school colors, and have compiled 

a database of schools and their colors in Excel. 

=countif (F1:F230, “=red”) 

If a cell in F1:F230 satisfies “=red”, then increment the active cell by one. 

SUMIF 

=sumif(range,criteria,sum_range) 

The “sumif” function utilizes a range and a corresponding sum_range of the same size.  

Example: 

You wish to know how many hours you have spent watching television, from a database of your time 

spent on various activities. 

=sumif (D1:D230,”=television”, H1:H230) 

If a cell in D1:D230 satisfies “=television”, then increment the active cell by the corresponding cell 

from H1:H230. If cell D7contains the word “television,” the active cell will be incremented from the 

corresponding cell from H1:H230, or cell H7. 

AND and OR 

=AND(condition1, [condition2], …) 

=OR(condition1, [condition2], …) 

For example, 

=AND(G2=”BLAH”,A2=”OCHO”) 

will evaluate to TRUE if the cell G2 is “BLAH” and the cell A2 is “OCHO”. 

OR will evaluate to TRUE if any of the conditions are true. 

For example, 



=OR(E2>12,F2<54) 

evaluates to TRUE if E2>12, or F2<54, or if both of the conditions are true!    

2.13 Format & Modify Text with Functions:  
1. Making use of LEFT, RIGHT and MID Excel functions. 

2. Removing spaces with the TRIM function. 

3. Using LOWER and UPPER functions. 

4. Joining text items to make one with the CONCATENATE function. 

2.14 Summarize Data by using Functions : 
1. SUM – Use this function to find the sum of the values in a column. ... 

2. AVERAGE – Use this function to find the average of the values in a column. ... 

3. COUNT – Use this function to count how many items are present in any range that  contains data. 

3. Apply Custom Data Formats and Validation : 

 

 Microsoft Excel has several built-in data validation rules for numbers, dates and text, but they   cover only the most 

basic scenarios. If you want to validate cells with your own criteria, create a custom validation rule based on a formula. 

Here's how: 

1. Select one or more cells to validate. 

2. Open the Data Validation dialog box. For this, click the Data Validation button on the Data tab, in the Data 

Tools group or press the key sequence Alt > D > L (each key is to be pressed separately). 

3. On the Settings tab of the Data Validation dialog window, select Custom in the Allow box, and enter your data 

validation formula in the Formula box. 

4. Click OK. 

Create and modify simple macros:  

     An Excel macro is an action or a set of actions that you can record, give a name, save and run as 

many times as you want and whenever you want. When you create a macro, you are recording your 

mouse clicks and keystrokes. When you run a saved macro, the recorded mouse clicks and keystrokes 

will be executed in the same sequence as they are recorded. Macros help you to save time on repetitive 

tasks involved in data manipulation and data reports that are required to be done frequently. 

Creation of Macros: 

Excel Macros7You can create a macro with Excel commands by recording the key strokes and mouse 

clicks, giving the macro a name and specifying how to store the macro. A macro thus recorded can be 

run with an Excel command. 

1. To record a macro do the following  

2. Click the VIEW tab on the Ribbon. 

3. Click Macros in the Macros group. 

4. Select Record Macro from the dropdown list 

The Record Macro dialog box appears. 

1. Type MyFirstMacro in the Macro name box. 

2. Type A Simple Macro in the Description box and click OK. 

3. Click in the cell B2. 

4. Create the table. 

5. Click in a different cell in the worksheet. 

6. Click the VIEW tab on the Ribbon. 

7. Click Macros. 

8. Select Stop Recording from the dropdown list. 

Modify simple macros:  
1. Click the Developer tab. 

2. Click the Macros button. 



The Macro dialog box appears. Here you can see the macros that you have recorded. 

3. Select a macro to edit. 

4. Click the Edit button. 

The Microsoft Visual Basic for Applications program appears. What may look like jumbled text is actually Visual 

Basic code—the language that was used by Excel to record the macro you created. 

You don’t have to learn Visual Basic to be proficient at Excel however, knowing the basics can be helpful if you ever 

want to modify an existing macro. If you take a close look at the code for your macro, some of the procedures should 

make a little sense to you. For example, if your macro selects some cells in a workbook, you may see the text “Select” 

or “Selection”. 

You can delete sections of code to delete certain actions from the macro or edit the code to change the macro’s 

actions. 

5. Edit the macro’s code as desired. 

6. Click the Save button. 

7. Close the Visual Basic for Applications program window 

3.6 Insert and configure form controls 

Insert a Form Control 

1. Click the Developer tab. 

2. Click the Insert button. There are two categories of controls in the menu. ... 

3. Select a form control. 

4. Click, or click and drag, to place the form control. 

5. Right-click the form control. 

6. Select Format Control. ... 

7. Modify the form control settings. ... 

8. Click OK. 

Create Charts:  
Create a new chart:  

1. Select the data for which you want to create a chart. 

2. Click INSERT > Recommended Charts. 

3. On the Recommended Charts tab, scroll through the list of charts that Excel    recommends for your data, and 

click any chart to see how your data will look. ... 

4. When you find the chart you like, click it > OK. 

Add additional data series: 
1. On the worksheet that contains your chart data, in the cells directly next to or below your existing source 

data for the chart, enter the new data series you want to add. ... 

2. Click anywhere in the chart. ... 

3. On the worksheet, drag the sizing handles to include the new data. 

Switch between rows and columns in source data: 
1. Copy the cell range. 

2. Select the empty cells where you want to paste the transposed data. 

3. On the Home tab, click the Paste icon, and select Paste Transpose. 

Analyze data by using Quick Analysis: 
1. Select a range of cells. 

2. Select the Quick Analysis button that appears at the bottom right corner of the selected data. ... 

3. Select Charts. 

4. Hover over the chart types to preview a chart, and then select the chart you want. 

5. Select More > All Charts to all available see all charts available. 

Format Charts:  
On the Format tab, in the Current Selection group, click the arrow next to the Chart Elements box, and then select the 

chart element that you want to format. 



One of the major uses of Excel is to create different types of charts for a given data set. Excel provides us with a lot 

of modification options to perform on these charts to make them more insightful. 

In this article, we are going to see the most common “Formatting” performed on charts using a suitable example 

shown below. 

Example: Consider the performance of a batsman in a T20 match. The data set contains the runs scored by the 

batsman in various matches.  

Now we will insert a bar chart using the above table. To insert a bar chart : 

Select dataset -> Click on Insert -> Chart Sets Pop Down -> 2-D column 

The key steps to format anything on the chart is : 

 Select the part of the chart which needs to be formatted. 

 Right-click on it and select “Format” The format window will open. 

Resize charts : 

Usually, we move or change the size of the chart within excel to ensure that the chart will not cover its 

underlying data. We can move the chart to a new location in the worksheet or to a new or existing worksheet. 

Also, we resize or change the size of the chart for a better fit in the worksheet. 

 

Add and modify chart elements: 

Add chart elements 

To insert a chart, select the data you wish to appear in the chart, and then go to the Insert ribbon (if the data is 

noncontiguous, you can select one set, and hold down the Control key on the keyboard to select the second set). 

In the Charts group, choose the desired type of chart. Click on the arrow below the type icon to see the sub-types. 

Excel 2013 also includes an option to browse Recommended Charts, which shows you the chart types that best 

fit your data. 

By default, the chart will appear directly on the spreadsheet where your data is; when the chart is selected, you 

will see additional ribbons. In Excel 2010, you have the Design, Layout, and Format Ribbons. In Excel 2013, you 

have Design and Format. The 'Layout' options have been consolidated into the Design ribbon. 

Modify chart elements 

Once your chart appears in Excel, there are many ways to modify the way it looks and its location. A few ways 

are described below, but explore to find more! In all cases, you have to select the chart first to access Chart Tools. 

 To add any labels (for example, the title or axes), under the Design ribbon, click Add Chart Element in 

the Chart Layouts group and select the desired label. 

 To change the chart type, data, or location, use the Chart Tools Design ribbon. 

 Apply chart layouts and styles: 
Built-in chart layouts can quickly adjust the overall layout of a chart with different combinations of titles, labels, and 

chart orientations. Select the chart you want to format. Click the Design tab. Click the Quick Layout button. Select the 

layout you want to use. 

Move charts to a chart sheet: 

Under Chart Tools, on the Design tab, in the Location group, click Move Chart. Do one of the following: To move the 

chart to a new worksheet, click New sheet, and then in the New sheet box, type a name for the worksheet. 

How to Create a chart 

Steps used to create a chart 

1. Select the data for which you want to create a chart. 

2. Click INSERT > Recommended Charts. 

3. On the Recommended Charts tab, scroll through the list of charts that Excel recommends for your data, and click 

any chart to see how your data will look.  If you don’t see a chart you like, click All Charts to see all the available chart 

types. 

4. When you find the chart you like, click it > OK. 



5. Use the Chart Elements, Chart Styles, and Chart Filters buttons, next to the upper-right corner of the chart to add 

chart elements like axis titles or data labels, customize the look of your chart, or change the data that is shown in the 

chart. 

6. To access additional design and formatting features, click anywhere in the chart to add the CHART TOOLS to 

the ribbon, and then click the options you want on the DESIGN and FORMAT tabs. 

Give the procedure to perform operations on worksheet in MS-Excel 

Some Common Operations in Microsoft Excel 

Deleting a Column or a Row 

Click on the column or row header to highlight the entire column or row to be deleted. Right-click on any cell in the 

highlighted column or row. Click on Delete from the menu. 

Inserting a Column 

Click on the column header directly to the right of where you want to insert a new column. Right-click on any cell in 

the highlighted column. Click on Insert from the menu. 

Inserting a Row 

Click on the row header directly below where you want to insert a new row. Right-click on any cell in the highlighted 

row. Click on Insert from the menu. 

Sorting 

Click on the grey rectangle between the "A" column header and the "1" row header in the upper left corner of the 

worksheet to select the entire worksheet. Click on Data on the menu bar, and then Sort... Under Sort by, select the 

column to sort by and select either Ascending or Descending order. 

Displaying Formulas in the Worksheet 

Hold down the CTRL key, and press the left single quote key (this key also has the "tilde" (~) symbol). Repeat this 

operation to return to numerical display. Note: spreadsheet data can be printed in either the formula display or the 

numerical display. 

Entering Formulas 

Click on the cell in which you want to enter a formula, and type the formula. Note: all formulas must begin with an 

equal sign (=). Additional information about functions can be obtained by clicking on the equal sign (=) next to the 

formula bar. 

Adjusting Column Width 

Click on the column header to highlight the entire column. Right-click on any cell in the highlighted column.  

Adjusting Row Height 

Click on the row header to highlight the entire row. Right-click on any cell in the highlighted row.  

Adjusting the Format of Numerical Data 

Click and drag over the cells containing the numerical data. Right-click on any cell in the highlighted area. Click 

on Format Cells... Click on the Number tab, and select the Category: for the type of data in the cells.  

Justification of Cell Contents 

Click on the cell. Click on the justification button (i.e., either left justify, center, or right justify) on the Formatting 

Toolbar. Note: these three buttons are found to the right of the bold, italics and underline buttons. 

Justification of an Entire Column or Row 

Click on the column or row header to highlight the entire column or row. Click on the justification button (i.e., either 

left justify, center, or right justify) on the Formatting Toolbar. Note: these three buttons are found to the right of the 

bold, italics and underline buttons. 

Copying Cells, Columns or Rows 

Select the cell(s), column(s) or row(s) by highlighting them. Right-click on any cell in the highlighted area. Click 

on Copy. The selected cells will be copied (transparently) to the Windows clipboard. Note: the Windows clipboard 

holds only the last copied data. 

Pasting Cells, Columns or Rows 

Select the cell(s), column(s) or row(s) into which you want to paste previously copied data (i.e., from the Windows 

clipboard). Note: the selected area must be the same size as the data you will be pasting. Right-click on any cell in the 

highlighted area. Click on Paste. 

Types of Functions in MS Excel 



Excel has many premade formulas, called functions. 

Functions are typed by = and the functions name. 

For example =SUM 

Once you have typed the function name you need to apply it to a range. 

For example =SUM(A1:A5) 

The range is always inside of parentheses. 

Function Description 

=AND Returns TRUE or FALSE based on two or more conditions 

=AVERAGE Calculates the average (arithmetic mean) 

=CONCAT Links together the content of multiple cells 

=COUNT Counts cells with numbers in a range 

=COUNTIF  Counts cells as specified 

=IF  Returns values based on a TRUE or FALSE condition 

=LEFT Returns values from the left side of a cell 

=LOWER Reformats content to lowercase 

=MAX Returns the highest value in a range 

=MIN  Returns the lowest value in a range 

=MODE Finds the number seen most times. The function always returns a single number 

=NPV The NPV function is used to calculate the Net Present Value (NPV) 

=OR Returns TRUE or FALSE based on two or more conditions 

=RAND Generates a random number 

=RIGHT  Returns values from the right side of a cell 

=STDEV.P Calculates the Standard Deviation (Std) for the entire population 

=STDEV.S Calculates the Standard Deviation (Std) for a sample 

=SUM Adds together numbers in a range 

=SUMIF  Calculates the sum of values in a range based on a TRUE or FALSE condition 

=TRIM  Removes irregular spacing, leaving one space between each value 

=VLOOKUP Allows vertical searches for values in a table 

=XOR Returns TRUE or FALSE based on two or more conditions 

Charts in MS Excel 

There is a list of basic and advanced level of charts used for different purposes to interpret the data. 

1. Column Chart 

2. Line Chart 

3. Bar Chart 

4. Area chart 

5. Pie chart or Doughnut chart 

6. Surface chart 

These are the most used charts of Excel that an Excel user usually requires. 

Microsoft Excel introduce one more new chart called Treemap chart for 2016 and newer version. It has come with 

some advanced features and representation styles. 

We will illustrate each chart and its functionality with an example in this chapter. Learn carefully and use them 

accordingly. 

Column Charts 

A column chart is basically a vertical chart that is used to represent the data in vertical bars. It works efficiently with 

different types of data, but it is usually used for comparing the information. 
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Excel offers 2D and 3D column charts. 

 

Line Chart 

Line charts are most useful for showing trends. Using this chart, you can easily analyze the ups and downs in your data 

over time. In this chart, data points are connected with lines. 

For example, a company wants to analyze the sell of products for the last five years graphically. Additionally, it also 

wants to analyze the ups and downs of each year product sell. 

 
Excel offers 2D and 3D line charts. 

Bar chart 

Bar charts are horizontal bars that work like column charts. Unlike column charts, Bar charts are horizontally plotted. 

Or you can say that bar charts and column charts are just opposite to each other. 

 
Area chart 

Area charts are just like line charts. Unlike the line charts, gaps are filled with color in area charts. Area charts are easy 

to analyze the growth in business as its shows ups and downs through line. 

 
Similar to the line charts, data points in area charts are connected with lines. 

Pie chart 

A pie chart is a rounded shape graph that is divided into slices of pie. Using this chart, you can easily analyze data that 

is divided into slices. It makes the data easy to compare the proportion. 

 
Surface chart 

Surface chart is actually a 3D chart that helps to represent the data into a 3D landscape. These charts are best to use 

with a large dataset. This chart allows to displaying a variety of data at the same time. 
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