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1. FUNDAMENTALS OF COMPUTER 
 

1.1  Introduction to Computers 
 Definition of a Computer: 

A computer is an electronic device that manipulates information, or data. It has the ability 

to store, retrieve, and process data. You may already know that you can use a computer to type 

documents, send email, play games, and browse the Web. You can also use it to edit or 

create spreadsheets, presentations, and even videos. The basic parts of a desktop computer are 

the computer case, monitor, keyboard, mouse, apnd power cord. Each part plays an important 

role whenever we use a computer. 

 

1.2 Characteristics and Limitations of Computer 
 Characteristics: 

    Speed 
Speed means the duration computer system requires in fulfilling a task or completing an activity. It 

is well-known that computers need very little time than humans in completing a task. Generally, 

humans take into account a second or minute as a unit of time. 

      Accuracy 
Accuracy means the level of precision with which calculations are made and tasks are performed. 

One may invest years of his life in detecting errors in computer calculations or updating a wrong 

record. 

     Reliability 
Reliability is the quality due to which the user can stay dependable on the computer. Computers 

systems are well-adjusted to do repetitive tasks.  

    Adaptability 
Adaptability of computer system means the quality of it to complete a different type of tasks: simple 

as well as complex.  

    Storage 
Storage is the ability of the computer to store data in itself for accessing it again in future. Nowadays, 

apart from having instantaneous access to data, computers have a huge ability to store data in a little 

physical space. 

     Limitations of Computer Systems 

     Limitations are the drawbacks of the computer system in which humans outperform them. 

    Lack of common-sense 
This is one of the major limitations of computer systems. No matter how efficient, fast and reliable 

computer systems might be but yet do not have any common sense because no full-proof algorithm has 

been designed to programme logic into them. As computers function based on the stored programme(s), 

they simply lack common sense. 

    Zero IQ 

    Another of the limitations of computer systems is that they have zero Intelligence Quotient (IQ). 

   Lack of Decision-making 

Decision-making is a complicated process involving information, knowledge, intelligence, wisdom, and 

ability to judge. The computer system does not have the ability to make decisions on their own because 

they do not possess all the essentials of decision-making. 

 



1.3 Block Diagram of a Computer 

 

1.4 Architecture of a Computer 

1. Input: This is the process of entering data and programs in to the computer system. You should 

know that computer is an electronic machine like any other machine which takes as inputs raw data 

and performs some processing giving out processed data. Therefore, the input unit takes data from us 

to the computer in an organized manner for processing.  

2. Storage: The process of saving data and instructions permanently is known as storage. Data has 

to be fed into the system before the actual processing starts. It is because the processing speed of 

Central Processing Unit (CPU) is so fast that the data has to be provided to CPU with the same speed. 

Therefore the data is first stored in the storage unit for faster access and processing. This storage unit 

or the primary storage of the computer system is designed to do the above functionality. It provides 

space for storing data and instructions.  

The storage unit performs the following major functions:  

All data and instructions are stored here before and after processing.  

• Intermediate results of processing are also stored here.  

Processing: The task of performing operations like arithmetic and logical operations is called 

processing. The Central Processing Unit (CPU) takes data and instructions from the storage unit and 

makes all sorts of calculations based on the instructions given and the type of data provided. It is then 

sent back to the storage unit.  

Control: The manner how instructions are executed and the above operations are performed. 

Controlling of all operations like input, processing and output are performed by control unit. It takes 

care of step by step processing of all operations inside the computer.   

Output: This is the process of producing results from the data for getting useful information. 

Similarly the output produced by the computer after processing must also be kept somewhere inside 

the computer before being given to you in human readable form. Again the output is also stored inside 

the computer for further processing.  

Arithmetic Logical Unit (ALU)   

Logical Unit: After you enter data through the input device it is stored in the primary storage unit. 

The actual processing of the data and instruction are performed by Arithmetic Logical Unit. The 

http://ecomputernotes.com/fundamental/introduction-to-computer/control-unit
http://ecomputernotes.com/fundamental/information-technology/what-do-you-mean-by-data-and-information
http://ecomputernotes.com/fundamental/input-output-and-memory/what-is-primary-storage


major operations performed by the ALU are addition, subtraction, multiplication, division, logic and 

comparison. Data is transferred to ALU from storage unit when required. After processing the output 

is returned back to storage unit for further processing or getting stored.  

Control Unit (CU)   

The next component of computer is the Control Unit, which acts like the supervisor seeing that things 

are done in proper fashion. Control Unit is responsible  for  co ordinating various operations using 

time signal. The control unit determines the sequence in which computer programs and instructions 

are executed. Things like processing of programs stored in the main memory, interpretation of the 

instructions and issuing of signals for other units of the computer to execute them. It also acts as a 

switch board operator when several users access the computer simultaneously. Thereby it coordinates 

the activities of computer’s peripheral equipment as they perform the input and output.  

Central Processing Unit (CPU)  

The ALU and the CU of a computer system are jointly known as the central processing unit. You 

may call CPU as the brain of any computer system. It is just like brain that takes all major decisions, 

makes all sorts of calculations and directs different parts of the computer functions by activating and 

controlling the operations. 

1.5 Types of Computers 

Personal Computer: 
A single person defines the personal computer, or PC, as any computer designed for general use by 

one person. While a Mac is a PC, most people relate the term with computers that run the Windows 

operating system. PCs were first known as microcomputers because they were a complete computer 

but built on a smaller scale than the huge systems in use by most businesses. Personal computers 

come in many forms, including the new Apple iPad. 

 

Desktop PC: 
 that is not designed for portability is a desktop computer. The expectation with desktop systems is 

that you will set the computer up in a permanent location, like a desk or table. Most desktops offer 

more power, storage and versatility for less cost than their portable brethren. 

 

Laptop:  
Also called notebooks, laptops are portable computers that mix the display, keyboard, a pointing 

device or trackball, processor, memory and hard drive all in a battery‐operated package slightly larger 

than an average hardcover book. On the left is a picture of Apple CEO Steve Jobs holding up the 

MacBook Pro Air. 

 

Tablet Computers: 
Tablet Computers are ultra-‐portable computers that are even smaller than traditional laptops. Their 

low cost means they're cheaper than almost any brand-‐new laptop you'll find at retail outlets. 

However, the internal components are less powerful than those in regular laptops. Recent 

improvements to tablet computers have allowed users to view HD video, get high quality sound, great 

photo capabilities, and the ability to share information, photos, and videos with anyone. 

 

Smart Phones: 

Smart phones are handheld-‐sized computers that often use flash memory instead of a hard drive for 

storage. These devices usually do not have keyboards but rely on touch screen technology for user 

input. Smart phones are typically smaller than a paperback novel, very lightweight with a reasonable 

battery life. Smartphones have the same capabilities as tablet computers, but also allow users to text 

or make phone calls. 

 

http://ecomputernotes.com/fundamental/introduction-to-computer/what-is-cpu


Workstation: 
Another type of computer is a workstation. A workstation is simply a desktop computer that has a 

more powerful processor, additional memory and enhanced capabilities for performing a special 

group of task, such as 3D Graphics or game development. They may even use multiple screens to 

enhance their viewing.  

 

Server: 
A computer that has been optimized to provide services to other computers over a network. Servers 

usually have powerful processors, lots of memory and large hard drives. Servers allow many 

computers to share a printer or other devices without the cost of having to buy one for every computer. 

Servers also allow users to share information and files with each other. The computers in this lab are 

part of a network. 

 

Mainframe: 
In the early days of computing, mainframes were huge computers that could fill an entire room or 

even a whole floor! As the size of computers has diminished while the power has increased, the term 

mainframe has fallen out of use in favour of enterprise server. You'll still hear the term used, 

particularly in large companies to describe the huge machines processing millions of transactions 

every day. Mainframes store vast amounts of information. 

 

Super Computer: 
This type of computer usually costs hundreds of thousands or even millions of dollars. Although some 

supercomputers are single computer systems, most are composed of multiple high performance 

computers working in parallel as a single system. Super computers are the fastest, most powerful, 

most expensive computers made today. The best-‐known supercomputers are built by Cray Super 

computers. Many of today’s great movies use supercomputers for their CGI. They can perform over 

a trillion calculations per second. 

 

 

Wearable Computers: 
The latest trend in computing is wearable computers. Essentially, common computer applications (e-‐
mail, database, multimedia, calendar/scheduler) are integrated into watches, cell phones, visors and 

even clothing. Users can use these devices for health and fitness, navigation, social networking, and 

gaming. Google can now augment a person’s vision through special computer glasses. The glasses 

can stream information to the lenses and allow the wearer to send and receive messages through voice 

commands.  

 

1.6 Types of Software: 

 
System Software 
System software is computer software designed to operate the computer hardware to provide basic 

functionality and to provide a platform for running application software. It refers to the operating 

system and all utility programs that manage computer resources at a low-level. 

 

Programming Software 
Programming software include tools in the form of programs or applications that software developers 

use to create, debug, maintain, or otherwise support other programs and applications. The term 

usually refers to relatively simple programs such as compilers, debuggers, interpreters, linkers, and 

text editors. 

 

Application Software  
A program or group of programs designed for end users. Allows end users to accomplish one or 

more specific (non - computer related) tasks. 

 

1.7 Memories 



 
RAM (random access memory) 

 

RAM is your system's short-term memory. Whenever your computer performs calculations, it 

temporarily stores the data in the RAM until it is needed. 

This short-term memory disappears when the computer is turned off. If you're working on a 

document, spreadsheet, or other type of file, you'll need to save it to avoid losing it. When you save 

a file, the data is written to the hard drive, which acts as long-term storage. 

 

RAM is measured in megabytes (MB) or gigabytes (GB). The more RAM you have, the more 

things your computer can do at the same time. If you don't have enough RAM, you may notice that 

your computer is sluggish when you have several programs open. Because of this, many people 

add extra RAM to their computers to improve performance. 

Hard disk 

 
The hard drive is where your software, documents, and other files are stored. The hard drive is long-

term storage, which means the data is still saved even if you turn the computer off or unplug it. 

 

When you run a program or open a file, the computer copies some of the data from the hard 

drive onto the RAM. When you save a file, the data is copied back to the hard drive. The faster the 

hard drive, the faster your computer can start up and load programs. 

Expansion cards 

Most computers have expansion slots on the motherboard that allow you to add various types 

of expansion cards. These are sometimes called PCI (peripheral component interconnect) cards. 

You may never need to add any PCI cards because most motherboards have built-in video, sound, 

network, and other capabilities. 

 

However, if you want to boost the performance of your computer or update the capabilities of an 

older computer, you can always add one or more cards. Below are some of the most common types 

of expansion cards. 



Video card 

 
The video card is responsible for what you see on the monitor. Most computers have a GPU 

(graphics processing unit) built into the motherboard instead of having a separate video card. If you 

like playing graphics-intensive games, you can add a faster video card to one of the expansion slots to 

get better performance. 

1.8Input and Output Devices: 

Hardware 
Hardware refers to the physical elements of a computer. This is also sometime called the machinery or the 

equipment of the computer. Examples of hardware in a computer are the keyboard, the monitor, the mouse 

and the central processing unit. However, most of a computer's hardware cannot be seen; in other words, it 

is not an external element of the computer, but rather an internal one, surrounded by the computer's casing 

(tower). A computer's hardware is comprised of many different parts, but perhaps the most important of 

these is the motherboard. The motherboard is made up of even more parts that power and control the 

computer. 

 

Software: 

Software, commonly known as programs or apps, consists of all the instructions that tell the hardware how 

to perform a task. These instructions come from a software developer in the form that will be accepted by 

the platform (operating system + CPU) that they are based on. For example, a program that is designed for 

the Windows operating system will only work for that specific operating system. Compatibility of software 

will vary as the design of the software and the operating system differ. Software that is designed for 

Windows XP may experience a compatibility issue when running under Windows 2000 or NT. 

 

Computer case 

 
The computer case is the metal and plastic box that contains the main components of the computer, 

including the motherboard, central processing unit (CPU), and power supply. The front of the case 

usually has an On/Off button and one or more optical drives. Computer cases come in different 

shapes and sizes. A desktop case lies flat on a desk, and the monitor usually sits on top of it. A tower 

case is tall and sits next to the monitor or on the floor. All-in-one computers come with the internal 

components built into the monitor, which eliminates the need for a separate case. 

 

Monitor 
The monitor works with a video card, located inside the computer case, to display images and text 

on the screen. Most monitors have control buttons that allow you to change your monitor's display 

settings, and some monitors also have built-in speakers. 

http://www.webopedia.com/TERM/H/hardware.html
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Newer monitors usually have LCD (liquid crystal display) or LED (light-emitting diode) displays. 

These can be made very thin, and they are often called flat-panel displays. Older monitors 

use CRT (cathode ray tube) displays. CRT monitors are much larger and heavier, and they take up 

more desk space. 

 

Keyboard 
The keyboard is one of the main ways to communicate with a computer. There are many different 

types of keyboards, but most are very similar and allow you to accomplish the same basic tasks. 

Click the buttons in the interactive below to learn about the different parts of the keyboard. 

 
If you want to learn how to type or improve your touch-typing skills, check out our free  

Typing Tutorial. 

 

Mouse 

The mouse is another important tool for communicating with computers. Commonly known as 

a pointing device, it lets you point to objects on the screen, click on them, and move them. 

There are two main mouse types: optical and mechanical. The optical mouse uses an electronic eye 

to detect movement and is easier to clean. The mechanical mouse uses a rolling ball to detect 

movement and requires regular cleaning to work properly. 

To learn the basics of using a mouse, check out our interactive Mouse Tutorial. 

 

Mouse alternatives: 
There are other devices that can do the same thing as a mouse. Many people find them easier to use, 

and they also require less desk space than a traditional mouse. The most common mouse alternatives 

are below. 

 Trackball: A trackball has a ball that can rotate freely. Instead of moving the device 

like a mouse, you can roll the ball with your thumb to move the pointer. 

 

 Touchpad: A touchpad—also called a trackpad—is a touch-sensitive pad that lets you 

control the pointer by making a drawing motion with your finger. Touch pads are 

common on laptop computers. 

http://www.gcflearnfree.org/typing/typing/1/
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Front of a computer case: 
Click the buttons in the interactive below to become familiar with the front of a computer. 

 

Back of a computer case 

The back of a computer case has connection ports that are made to fit specific devices. The 

placement will vary from computer to computer, and many companies have their own special 

connectors for specific devices. Some of the ports may be color coded to help you determine which 

port is used with a particular device. 

Click the buttons in the interactive below to become familiar with the back of a computer. 

 
Peripherals used with computer: 

The most basic computer setup usually includes the computer case, monitor, keyboard, and mouse, 

but you can plug many different types of devices into the extra ports on your computer. These devices 

are called peripherals. Let's take a look at some of the most common ones. 

 

Printers: A printer is used to print documents, photos, and anything else that appears on your 

screen. There are many types of printers, including inkjet, laser, and photo printers. There are 

even all-in-one printers, which can also scan and copy documents. 

 



Scanners: A scanner allows you to copy a physical image or document and save it to your 

computer as a digital (computer-readable) image. Many scanners are included as part of an all-

in-one printer, although you can also buy a separate flatbed or handheld scanner. 

 

Speakers/headphones: Speakers and headphones are output devices, which means they send 

information from the computer to the user—in this case, they allow you to hear sound and 

music. Depending on the model, they may connect to the audio port or the USB port. Some 

monitors also have built-in speakers. 

 

Microphones: A microphone is a type of input device, or a device that receives information from 

a user. You can connect a microphone to record sound or talk with someone else over the Internet. 

Many laptop computers come with built-in microphones. 

 

 

Web cameras: A web camera—or webcam—is a type of input device that can record videos and 

take pictures. It can also transmit video over the Internet in real time, which allows for video 

chat or video conferencingwith someone else. Many webcams also include a microphone for this 

reason. 

 
Game controllers and joysticks: A game controller is used to control computer games. There are 

many other types of controllers you can use, including joysticks, although you can also use 

your mouse and keyboard to control most games. 

 

Digital cameras: A digital camera lets you capture pictures and videos in a digital format. By 

connecting the camera to your computer's USB port, you can transfer the images from the camera to 

the computer. 

 

Mobile phones, MP3 players, tablet computers, and other devices: Whenever you buy an 

electronic device, such as a mobile phone or MP3 player, check to see if it comes with a USB cable. 

If it does, this means you can most likely connect it to your computer. 

 

Inside a computer 

Motherboard 

The motherboard is the computer's main circuit board. It's a thin plate that holds the CPU, memory, 

connectors for the hard drive and optical drives, expansion cards to control the video and audio, and 



connections to your computer's ports (such as USB ports). The motherboard connects directly or 

indirectly to every part of the computer. 

CPU/processor 

The central processing unit (CPU), also called a processor, is located inside the computer case on 

the motherboard. It is sometimes called the brain of the computer, and its job is to carry out 

commands. Whenever you press a key, click the mouse, or start an application, you're sending 

instructions to the CPU. 

The CPU is usually a two-inch ceramic square with a silicon chip located inside. The chip is usually 

about the size of a thumbnail. The CPU fits into the motherboard's CPU socket, which is covered by 

the heat sink, an object that absorbs heat from the CPU. 

A processor's speed is measured in megahertz (MHz), or millions of instructions per second; 

and gigahertz (GHz), or billions of instructions per second. A faster processor can execute 

instructions more quickly. However, the actual speed of the computer depends on the speed of many 

different components—not just the processor. 

 



2. MS-WORD 

2.1 Introduction 

Word 2007 is like a typewriter on steroids! In this respect Word is no different from other word 

processing programs. Since the computer has become a common household and workplace 

item the typewriter has almost disappeared. Some people might have kept their typewriter, but 

that is mostly for sentimental reasons. 

 

Nowadays a typewriter is only used when a carbon copy is needed. If you do not need carbon 

copies, and if you have a personal computer (PC), you might just as well donate the old 

“chopping board” to a museum. 

 

Compared to the rest of the Office package, Word has in many versions been the most “over-

developed” program. Word can do everything you want when it comes to word processing; 

probably more than you or I will ever need. 

 

This is one reason why there have been very few new features in the latest versions of the 

program. It has mostly been cosmetic changes to the interface and small improvements of the 

Spell and Grammar Check. Word has not changed much in Version 2007 either. It is mostly the 

same both with respect to its strengths and weaknesses. 

 

There are some handy Templates for easy letter writing, and it is also easy to create some 

impressive graphics to support the text, but it is more difficult to place and text wrapping of 

pictures, and it can be quite a challenge to place captions. This has always been one of Word’s 

weaknesses and it is somewhat disappointing that nothing has been done to improve it. 

 

By virtue of its many possibilities, Word is a fairly complicated program, although it is relatively 

easy to work with. If you have never worked with Word before, you will probably soon find 

yourself in the wilderness of possibilities the program offers. In his book I will attempt to guide 

you through that wilderness, so you can learn the things that are necessary for you to use the 

program effectively. 

 

2.2 Features in Word 2007 
In many of the previous versions of Word, the changes have mostly been cosmetic. In version 

2007, Word is still essentially the same program, but on the surface there have been some 

significant changes that in many cases have made it easier to use. 

 

Ribbons and Tabs 
Like the other programs in the Office package, Word has gotten a new, smarter look. The most 

obvious change is that the traditional Menu and Toolbars have been replaced by the new Ribbon. 

The Ribbon contains Ribbon Tabs and every Tab contains buttons for the various functions that 

used to be located in the Menu and Toolbars. The Ribbon is far more visual and task-oriented; 

it constantly adapts to your current activity. 

 

If you are used to working with Menus and Toolbars, the Ribbon will take some getting used to, 

but once that has happened you will start appreciating it. Previously, many functions required 

that you click your way deep into menus and dialog boxes. In the Ribbon, many settings and 

functions have been pulled out, so they are more accessible. However, there are also a few 

unfortunate examples of functions that have become more difficult to use. Especially when it 

comes to Styles, the Ribbon should probably have been revised before publication. 

 

 

Shortcut Keys 



By simply pressing the ALT key on your keyboard some small boxes with numbers or letters 

will be displayed above the Quick Access Toolbar Office Button and the individual Tabs in the 

Ribbon. The numbers and letters that appear correspond to the key you should press to select 

the function. For this you no longer need to press the ALT key simultaneously. For example, if 

you press "N", the Insert Tab is displayed, and the features in this Tab will be automatically 

highlighted with shortcuts. All you need to do is press what is in the small boxes without 

pressing the ALT key. 

 

Figure 2.1: Viewing Shortcuts. 

 2.3 The Screen and its Elements 

In this section, we review the basic structure of Word 2007. You start the program by clicking 

the Windows Start Button at the bottom left, then click Programs. In the Programs menu there 

is a folder called Microsoft Office, and this is of course where you find Word. 

When you start Word, you automatically start in a new blank document. 

 

       Figure 2.2: Word and its Screen Elements. 

 

On its surface Word 2007 is a very simple and attractive program, and it is undoubtedly 

relatively easy to use, but there are some elements you need to familiarize yourself with. 

 

The Office Button 
In the upper left corner of the screen, you will find the round Office Button. It corresponds 

basically to the old "Files" menu. 

When you click on the Office Button, a menu pops up. It is this menu you must enter when you 

want to create a new blank document, and when you need to save it. You will also find menu 

items for Preview and Print. 

Quick Access 
The small, discrete ”Quick Access” Toolbar is located just to the right of the Office Button. Using 

Quick Access, you can save, undo, etc. with a single click.  The View Buttons 

With the View Buttons you can change the way your document is displayed. 

Print Layout 



Print Layout is the default View. In this View, what you see on the screen is similar to the 

print-out. This View is good when you type text, and it is excellent when you want to position 

pictures and graphics as well as when you need to adjust page setup and margins. This View 

is probably the one you will use most often. 

 

Full Screen Reading 

Full Screen Reading is reminiscent of the Print Layout, but Ribbons and various buttons 

are hidden, so the screen space is used to display the document. This is a good View when 

you need to read a document on the screen. 

 

Web Layout 

This View shows how your document would look if you saved it as a Web page. Word can 

save documents in HTML format, so you can actually create simple Web pages in the program. 

 

Outline 

This view differs somewhat from the others. To make use of it requires that you use 

Heading Styles. Outline View can display different levels of headers in your document, 

and it makes it easy to move around between entire sections and change the heading levels. 

If you are writing long reports or manuscripts, Outline View is a great tool when you need 

to organize your document, but it is not suitable for reading or writing. 

 

Draft 

Draft View is suitable for writing. If there are pictures and graphics in the document, they 

are not displayed, which means that this View does not require much of the computer. If 

your computer is a little weak and you need to read a large document, this may be an option. 

Otherwise I do not think you need to use this View. 

 

Zoom 

The Zoom feature is easy to use, but in my opinion it is better to hold down the CTRL key on 

your keyboard while scrolling up and down with the scroll wheel on your mouse. Of course 

this requires that you have a mouse with a scroll wheel. 

 

The Status Bar 
The Status Bar, in the bottom left of the screen, shows at all times which page you are on, how 

many pages there are in total, and how many words there are in the document. There is also a 

small icon that moves as you type. 

 

2.4 Creating a New Document 

When Word starts up, the program will display a new blank document - that is, a completely 

blank piece of paper which you can begin to write on. That is fine most of the time, but you do 

not have to start from a completely blank page. Word can help you lay out your documents 

neatly, so it is easy, for example, to design a nice letter. This is done through a variety of built-

in Templates that were installed with the program. You can download even more Templates 

from the Internet. If this is not enough for you, you can also create your own Templates once 

you are familiar with the program. 

 

Starting on a New Blank Document 

You do not have to confine yourself to working in one document at a time. You can have as 

many documents open as your computer's memory allows. In most cases, this means more 

than you will ever need. 



 

Let us try to start a couple of new documents, so you can get an idea of your options. 

 

1. Click on the Office Button in the top left corner of the screen. 

2. Click on New. (the exercise continues) 

 

You now have the opportunity to choose which Template you want to use. The Templates are 

organized in categories on the left side, which you can click on. The categories are divided into 

two groups. The group with already installed Templates is located at the top, and just below 

that is the group "Microsoft Office Online." To use the Templates in the last group requires 

Internet access, since there are a lot of Templates in this group, which would take up quite a 

lot of space on your hard drive. 

 
 

Starting a New Document from a Template 

As indicated above, we will try using a Template. I have chosen a letter Template that makes 

it easy to set up a nice letter. 

 

1. Click on the Office Button in the upper left corner of the screen. 

2. Click on New. 

3. In the left side, select Installed Templates. 

4. Select the Template Urban Letter. 

5. Double-click on the template or Click on the Create button. 

 

This opens a new mail document. Everything is set up, you just have to type your text into 

the different text fields. 

2.5 Writing and Simple Formatting 

Let us write some text, so we have something to work with. You must type the following text into a 

blank document. When I write "Press ENTER on the keyboard", you obviously do not write it, but press 

ENTER (or RETURN key, as some call it). 

Simple formatting 

When it is about simple formatting, it means selection of a piece of text to be rendered in another font, 

colour, alignment etc. When it gets more advanced, we will start working with Styles, which gives more 

options. 

 

1. Select the first line using the mouse. 

2. Select the Home Tab in the Ribbon. 

The Home Tab contains all the basic functions for formatting text. I am not sure why it is called 

the Home Tab, but it probably has to do with it being the one shown first. 

3. Click on the Bold Button in the Ribbon. It is the button with a ”B” on it. 



4. The first line is now in bold. 

5. Select once again the text you have just formatted 

6. Click on the Center Button. 

7. Again, make sure that the first line of text is selected. 

8. In the font changer, click the small arrow to the right of the font name. 

9. Click Arial Black on the list that appears 

10.  Similarly, change the font size to 16. You can do this either by selecting it from the 

list or by typing it directly into the field. 

 

2.6 Page Layout 

 
Margins 
There are three things to remember when aligning margins: 

As a rule of thumb, the margins should not be too small, meaning less than 1 cm. The pages will 

look too heavy if there is not enough space around the text. Conversely, 3 cm would probably 

look a little crazy on an A4 page. 

 

1.   First ensure that you are in the Print Layout View. Click on the View Tab in the 

Ribbon and make sure the Print Layout button is pressed. 

 2.      On the same Tab in the Ribbon, you must also make sure that the rulers are displayed. 

There should be a ”tick” by Ruler. 

 

To move the margin you simply press down the left mouse button when you see the double headed arrow 

and drag the margin with the mouse. 

 

Adjusting Margins – the Accurate Somewhat Slower way 

To adjust the margins with complete accuracy, click on the Margins button in the Page Layout Tab. This 

opens a menu where you can choose between five different pre-designed configurations, including a 

two- sided setup. But if you click Custom Margins, you get access to fine-tuning everything. 

 

Page Setup 

In Page Setup, you can set paper size, orientation, columns and margins. You can find the functions for 

Page Setup in the Page Layout Tab. 

 

Page Header and Footer 

In a nice report, you can put a little text and/or graphics at the top and bottom of each page. This could 

be the report title, the company logo and the page number. That is what headers and footers are for. 

 

2.7Tables 

You can create tables in Word. Whether you want to create a schedule, display accounting or 

something else, tables are often needed. Click on the Table button to open a menu. Choose six rows 

and four columns from the menu to have your document inserted in a very "raw" table 

1. Insert some headlines of your choice in the first row. Then enter a few figures in the 

other fields in the table. 

2. Select the Design Tab in the ribbon. 

3. Choose a "Table Style" to quickly add some color to the table. There are only a few 

styles visible in the Ribbon, but to the right of the Style buttons you can scroll through 

the list, giving you many more to choose from. 

 

2.8   Pictures and Graphics 
Insert a Picture from a File 



I assume that you have a picture on your computer that you can insert. We return once more to our 

exercise document. 

 

1. Place the cursor at the end of the document on page 3. 

2. Choose the Insert Tab in the Ribbon. 

3. Click on the Select Picture button. 

4. Find a suitable picture and click on the Insert button. 

5. Ensure the picture is highlighted, and that the Format Tab is selected in the Ribbon. 

6. Furthest to the right on the Ribbon, you have the possibility to adjust the height 

and length of the picture. 

7. Click the number indicating the width of the picture. 

8. Press the 5 key on the keyboard and press ENTER. 

 

 



3. MICROSOFT EXCEL 

3.1 Introduction 
Microsoft Excel is one of the most popular spreadsheet applications that helps you 

manage data, create visually persuasive charts, and thought-provoking graphs. Excel is 

supported by both Mac and PC platforms. Microsoft Excel can also be used to balance a 

checkbook, create an expense report, build formulas, and edit them. Opening Microsoft Excel 

To begin Microsoft Excel, Go to Applications > Microsoft Excel (Figure 1). When opened a 

Dialogue box on the screen, showing you a few templates and blank excel  sheets , if this does 

not happen click File > New Workbook 

 

Saving Your Document: Computers crash and documents are lost all the time, so it is 

best to save often. Saving Initially Before you begin you should save your document. To do this, 

go to File > Save As. Microsoft Excel will open a dialog box where you can specify the new 

file’s name , location of where you want it saved, and format of the document. Once you have 

specified a name, place, and format for your new file, press the Save button.  

Saving Later: After you have initially saved your blank document under a new name, 

you can begin your project. However, you will still want to periodically save your work as 

insurance against a computer freeze or a power outage. To save, click File > Save  

 

   3.2   Features of MS-Excel & Parts of MS-Excel window 
Microsoft Excel uses a ribbon toolbar to allow you to modify your document. Both Mac 

and Pc have the same ribbon toolbar. If you do not see these toolbars, or to open up other 

toolbars, go to View > Ribbon and place a checkmark by the toolbar you wish to open. Excel 

will also allow you to customize your toolbar by going to View > Customize Views. On Mac, 

there is grey toolbar located at the top of the green ribbon that contains any extra functions that 

is not in the main Excel ribbon. On Pc, excel has all of its functions in the main ribbon.  

 

  3.3 Formulas and Functions 
The Formula Bar in the formula bar, you can enter or edit data, a formula, or a function 

that will appear in a specific cell. In the image below, cell C1 is selected and 1984 is entered into 

the formula bar. Note how the data appears in both the formula bar and in cell C1. Cells can 

contain formulas and functions that calculate cell values. In our example, SUM(B4:B7) adds the 

value of each cell in cell range B4:B7and displays the total in cell B8. 

Formatting Attributes Cells can contain formatting attributes that change the way 

letters, numbers, and dates are displayed. For example, percentages can appear as 0.15 or 15%. 

You can even change a cell's background color. Formulas and Functions Cells can contain 

formulas and functions that calculate cell values. In our example, SUM(B4:B7) adds the value 

of each cell in cell range B4:B7and displays the total in cell B8.To insert content1.Click a cell 

to select it.2.Type content into the selected cell, then press Enter on your keyboard. The content 

will appear in the cell and the formula bar. You can also input and edit cell content in the formula 

bar. Content appears in cell and formula bar.  

To delete cell content1.Select the cell with content you wish to delete.2.Press the Delete or Backspace 

key on your keyboard. The cell's contents will be deleted. To delete cells: There is an important 

difference between deleting the content of a cell and deleting the cell itself. If you delete the entire cell, 

the cells below it will shift-up and replace the deleted cells. 

1. Select the cell(s)you wish to delete. 

2. Select the Delete command from the Home-tab on the Ribbon.  

3. The cells below will shift up. 

 

  3.4 Formatting Cells 
All cell content uses the same formatting by default, which can make it difficult to read a 

workbook with a lot of information. Basic formatting can customize the look and feel of your 

workbook, allowing you to draw attention to specific sections and making your content easier to view 

and understand. You can also apply number formatting to tell Excel exactly what type of data you’re 

using in the workbook, such as percentages (%), currency ($), and so on.  



Font Formatting 
To change the font By default, the font of each new workbook is set to Calibri. However, 

Excel provides a variety of other fonts you can use to customize your cell text. In the example below, 

we'll format our title cell to help distinguish it from the rest of the worksheet. 

1. Select the cell(s)you wish to modify.  

2. Click the drop-down arrow next to the Font command on the Home tab. The Font drop-

down menu will appear.  

3. Select the desired font. A live preview of the new font will appear as you hover the mouse 

over different options. 

4. The text will change to the selected font.  

To change the font color 

1. Select the cell(s) you wish to modify. 

2. Click the drop-down arrow next to the Font Color command on the Home tab. The 

Color menu will appear. 

3. Select the desired font color. A live preview of the new font color will appear as you 

hover the mouse over different options. 

 

Formatting the Spreadsheet: 
The default page view for Microsoft Excel spreadsheets display all gridlines and open 

up in portrait orientation. To change the gridlines look at the fifth tab on the Formatting Palette, 

under Sheet uncheck the view box. This will eliminate any gridlines from the spreadsheet. To 

change the page orientation look at the fifth tab on the Formatting Palette, under Orientation and 

check Landscape. 

 

Working with Cells: Cells are an important part of any project being used in Microsoft Excel. 

Cells hold all of the data that is being used to create the spreadsheet or workbook. To enter data 

into a cell you simply click once inside of the desired cell, a green border will appear around the 

cell. Cut, Copy, and Paste. You can use the Cut, Copy and Paste features of Excel to change the 

data within your spreadsheet, to move data from other spreadsheets into new spreadsheets, and 

to save yourself the time of re-entering information in a spreadsheet. Cut will actually remove 

the selection from the original location and allow it to be placed somewhere else. Copy allows 

you to leave the original selection where it is and insert a copy elsewhere. Paste is used to insert 

data that has been cut or copied. To Cut or Copy: Highlight the data or text by selecting the cells 

that they are held within. Go to Edit > Copy (Command-X) or Edit > Cut (Command-C).Click 

the location where the information should be placed. Go to Edit > Paste (Command-V). 

 

Formatting Cells 
There are various different options that can be changed to format the spreadsheets cells 

differently. When changing the format within cells you must select the cells that you wish to 

format. To get to the Format Cells dialog box select the cells you wish to change then go to 

Format > Cells. A box will appear on the screen with six different tab options (Number: Allows 

you to change the measurement in which your data is used. (If your data is concerned with money 

the number that you would use is currency)Alignment: This allows you to change the horizontal 

and vertical alignment of your text within each cell. You can also change the orientation of the 

text within the cells and the control of the text within the cells as well. Font: Gives the option to 

change the size, style, color, and effects. Border: Gives the option to change the design of the 

border around or through the cells. Formatting Rows and Columns When formatting rows and 

columns you can change the height, choose for your information to autofit to the cells, hide 

information within a row or column, un-hide the information. To format a row or column go to 

Format > Row (or Column), or Home tab then format button for PC, then choose which option 

you are going to use. The cell or cells that are going to be formatted need to be selected before 

doing this. Adding Rows and Columns When adding a row or column you are inserting a blank 

row or column next to your already entered data. Before you can add a Row you are going to 

have to select the row that your wish for your new row to be placed in its place. (Rows are on 

the left hand side of the spreadsheet) once the row is selected it is going to highlight the entire 



row that you chose. To insert the row you have to go to Insert > Row. The row will automatically 

be placed on the spreadsheet and any data that was selected in the original row will be moved 

down below the new row. Another way is using the Insert in the Formatting Pallete. 

 

  3.5 Working with Charts 
Charts are an important part to being able to create a visual for spreadsheet data. In 

order to create a chart within Excel the data that is going to be used for it needs to be entered 

already into the spreadsheet document. Once the data is entered, the cells that are going to be 

used for the chart need to be highlighted so that the software knows what to include. Next, click 

on the Charts Tab that is located right above the spreadsheet. Once it is clicked the tab will 

highlight green and all of the various charts within Excel will appear. You may choose the chart 

that is desired by clicking the icons that are displayed. Once the icon is chosen the chart will 

appear as a small graphic within the spreadsheet you are working on.  

To move the chart to a page of its own select the border of the chart and Ctrl > Click. 

This will bring up a drop down menu, navigate to the option that says Move Chart. This will 

bring up a dialog box that says Chart Location. From here you will need to select the circle next 

to As A New Sheet and name the sheet that will hold your chart. The chart will pop up larger in 

a separate sheet but in the same workbook as your entered data.  

 

Chart Design 
There are various different features that you can change to make your chart more appealing. To 

be able to make these changes you will need to have the chart selected or view the chart page 

that is within your workbook. Once you have done that the Formatting Palette will change to 

show features that were not there before (Figure 16). These features include: 

 

Chart Options 
Titles: Here you can change the Chart Title, Vertical Axis Title, and Horizontal Axis Title by 

clicking the drop down menu and selecting which one you will change and entering the name 

into the empty box below. 

Axes: You may change which axes are shown on the charts graph and which are not. 

Gridlines: This feature allows you to change which gridlines (major and minor) are shown on 

the charts graph and which are not. 

Chart Style: Here you are able to change the color of the bars that are within your chart. 

Quick Styles and Effects: Here you can add gradients, fill, drop shadows, and reflections to your 

chart depending on what is desired. 

 

Types of charts 
Excel has several different types of charts, allowing you to choose the one that best fits your 

data. In order to use charts effectively, you'll need to understand how different charts are used. 

Column charts use vertical bars to represent data. They can work with many different types of 

data, but they're most frequently used for comparing information. Line charts are ideal for 

showing trends. The data points are connected with lines, making it easy to see whether values 

are increasing or decreasing over time.Pie charts make it easy to compare proportions. Each 

value is shown as a slice of the pie, so it's easy to see which values make up the percentage of a 

whole.  

Bar charts work just like Column charts, but they use horizontal bars instead of vertical 

bars.Area charts are similar to line charts, except that the areas under the lines are filled 

in.Surface charts allow you to display data across a 3D landscape. They work best with large 

data sets, allowing you to see a variety of information at the same time. To insert a chart1.Select 

the cells you want to chart, including the column titles and row labels. These cells will be the 

source data for the chart.  

From the Insert tab, click the desired Chart command. Choose the desired chart type from the 

drop-down menu 

 

  3.6 Excel Macros 



An Excel macro is an action or a set of actions that you can record, give a name, save and run as 

many times as you want and whenever you want. When you create a macro, you are recording 

your mouse clicks and keystrokes. When you run a saved macro, the recorded mouse clicks and 

keystrokes will be executed in the same sequence as they are recorded. Macros help you to save 

time on repetitive tasks involved in data manipulation and data reports that are required to be 

done frequently. 

 

Creation of Macros: 
Excel Macros7You can create a macro with Excel commands by recording the key strokes and 

mouse clicks, giving the macro a name and specifying how to store the macro. A macro thus 

recorded can be run with an Excel command. 

1. To record a macro do the following  

2. Click the VIEW tab on the Ribbon. 

3. Click Macros in the Macros group. 

4. Select Record Macro from the dropdown list 

The Record Macro dialog box appears. 

1. Type My First Macro in the Macro name box. 

2. Type A Simple Macro in the Description box and click OK. 

3. Click in the cell B2. 

4. Create the table. 

5. Click in a different cell in the worksheet. 

6. Click the VIEW tab on the Ribbon. 

7. Click Macros. 

8. Select Stop Recording from the dropdown list. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. MS-POWER POINT 
4.1 Introduction 



The following screenshot shows the various areas in a standard PowerPoint file. It is important 

to familiarize yourself with these areas as it makes learning and using PowerPoint easier. 

 
 

File Tab  
This tab opens the Backstage view which basically allows you to manage the file and settings 

in PowerPoint. You can save presentations, open existing ones and create new presentations 

based on blank or predefined templates. The other file related operations can also be executed 

from this view. 

Ribbon Tab 
The ribbon contains three components:  

Tabs: They appear across the top of the Ribbon and contain groups of related commands. Home, 

Insert, Page Layout are examples of ribbon tabs.  

Groups: They organize related commands; each group name appears below the group on the Ribbon. 

For example, a group of commands related to fonts or a group of commands related to alignment, etc.  

Commands: Commands appear within each group as mentioned above.  

Title Bar  
This is the top section of the window. It shows the name of the file followed by the name of the 

program which in this case is Microsoft PowerPoint.  

Slide Area  



This is the area where the actual slide is created and edited. You can add, edit and delete text, 

images, shapes and multimedia in this section. 

Help  
The Help Icon can be used to get PowerPoint related help anytime you need. Clicking on the 

"?" opens the PowerPoint Help window where you have a list of common topics to browse 

from. You can also search for specific topics from the search bar at the top. 

 

Slide Views  
The group of four buttons located to the left of the Zoom control, near the bottom of the screen, lets 

you switch between PowerPoint views.  

Normal Layout view: This displays page in normal view with the slide on the right and a list of 

thumbnails to the left. This view allows you to edit individual slides and also rearrange them.  

Slide Sorter view: This displays all the slides as a matrix. This view only allows you to rearrange 

the slides but not edit the contents of each slide.  

Reading View: This view is like a slideshow with access to the Windows task bar in case you need 

to switch windows. However, like the slideshow you cannot edit anything in this view.  

 

Quick Access Toolbar  
The Quick Access Toolbar is located just under the ribbon. This toolbar offers a convenient place to 

group the most commonly used commands in PowerPoint. You can customize this toolbar to suit your 

needs.  

Slide Tab  
This section is available only in the Normal view. It displays all the slides in sequence. You 

can add, delete and reorder slides from this section. 

 

4.2 Creating Presentation  
 

PowerPoint offers a host of tools that will aid you in creating a presentation. These tools are 

organized logically into various ribbons in PowerPoint. The table below describes the various 

commands you can access from the different menus. 



 
 

Menu Category  Ribbon Commands  

Home  Clipboard functions, manipulating slides, 

fonts, paragraph settings, drawing objects 

and editing functions  

Insert  Insert tables, pictures, images, shapes, 

charts, special texts, multimedia and 

symbols  

Design  Slide setup, slide orientation, presentation 

themes and background  

Transitions  Commands related to slide transitions  

Animations  Commands related to animation within the 

individual slides  

Slideshow  Commands related to slideshow set up and 

previews  

Review  Proofing content, language selection, 

comments and comparing presentations  

View  Commands related to presentation views, 

Master slides, color settings and window 

arrangements  

 

 

 



4.3 Adding New Slides  
 

In this chapter, we will understand how to add new slides in an existing presentation. Here are the 

steps that allow you to insert a new slide in the deck:  

Step 1: Right-click in the Navigation Pane under any existing slide and click on the New Slide 

option. 

Step 2: The new slide is inserted. You can now change the layout of this slide to suit your 

design requirements. 

Step 3: To change the slide layout, right-click on the newly inserted slide and go to the Layout 

option where you can choose from the existing layout styles available to you. 

When we insert a new slide, it inherits the layout of its previous slide with one exception. If 

you are inserting a new slide after the first slide (Title slide), the subsequent slide will have the 

Title and Content layout. 

 

 
 

4.4 Adding Text in Boxes  
PowerPoint allows users to add text to the slide in a well-defined manner to ensure the content is well 

distributed and easy to read. The procedure to add the text in a PowerPoint slide is always the same - 

just click in the text box and start typing. The text will follow the default formatting set for the text 

box, although this formatting can be changed later as required. What changes is the different kinds of 

content boxes that support text in a PowerPoint slide.  

Given below are some of the most common content blocks you will see in PowerPoint.  

Title Box  
This is typically found on slides with the title layout and in all the slides that have a title box in them. 

This box is indicated by "Click to add title". 

Subtitle Box  
This is found only in slides with the Title layout. This is indicated by "Click to add subtitle".  

Content Box  
This is found in most of the slides that have a placeholder for adding content. This is indicated by 

"Click to add text". As you can see, this box allows you to add text as well as non-text content. To 

add text to such a box, click anywhere on the box, except on one of the content icons in the center 

and start typing. 

 



Text Only Box  
This is not a default content box available in PowerPoint, but you can create it using Slide Master, if 

required. This is also indicated by "Click to add text". The only difference between the Text Only 

Box and the Content Box is that the former only supports text in the content area. 

 

 

4.5 Adding New Text Boxes  
 

This chapter will teach you how to add new text boxes in a slide. Most of the standard layouts come 

with the text box option. As mentioned in the previous chapter, text boxes will have "Click to add 

text" as the default text. Here are the steps to add new text boxes in slide.  

Step 1: Click on the Text Box icon in the Home ribbon under the Drawing section. 

 
 

Step 2: You will get the insert text box cursor that looks like an inverted cross.  

Step 3: Click to insert a text box. You can now start typing directly into the text box. 

Step 4: Alternately, you can click and drag the cursor without releasing the click to create a text box. 

 

The size of the text box can be adjusted by selecting one of the edges marked by squares or 

corners marked by circles. 

 

 

 

4.6 Deleting Existing Slide  
 

There are times while building a slide deck, you may need to delete some slides. This can be done 

easily from PowerPoint. You can delete the slides from the Normal view as well as the Slide Sorter 

view. In each view, you can delete the slides in two ways.  

Deleting from Normal View  
Step 1: Go to the Normal view. 

Step 2: Right-click on the slide to be deleted and select the Delete Slide option.  

Alternately, you can select the slide and press the Delete button on your key board 

Deleting from Slide Sorter View  
Let us now understand how to deleted slides from the Slide Sorter View.  

Step 1: Go to the Slide Sorter view. 

Step 2: Right-click on the slide to be deleted and select the Delete Slide option. 

Alternately, you can select the slide and press the Delete button on your key board. 

 

4.7 Rearranging Slides  
 

Rearranging slides is important when it comes to organizing the overall presentation flow. While it 

is vital that you get the right content in every slide, it is equally important that you are able to present 

them in a format that makes it easier for the audience to understand the content too; most times this 

will require rearranging the slides.  



You can rearrange slides from two views in PowerPoint - Normal View and Slide Sorter View. 

Given below are the steps to rearrange slides from different views.  

Normal View  
Step 1: Select the slide to be moved  

Step 2: Left click on the slide and drag it to the position in the sequence where you want to 

place it. PowerPoint will indicate the insert position with a line in-between existing slides. 

 

 
 

Step 3: When you get to the right position release the left click button to insert the slide. 

Alternately you can also cut the selected slide and paste it back in the sequence as shown below. 

Slide Sorter View  
Let us now understand how the Slide Sorter View works.  

Step 1: Select the slide to be moved.  

Step 2: Left click on the slide and drag it to the position in the sequence where you want to place 

it. PowerPoint will indicate the insert position with a line in-between existing slides. 

Step 3: When you get to the right position, release the left click button to insert the slide  

Alternately you can also cut the selected slide and paste it back in the sequence as shown below. 

 

4.8 Adding Slide Notes 
 

Slide notes can be very useful tools for presentation. These notes are not displayed on the screen 

in the Slideshow mode, but the presenter can see them so they can prepare well to present the 

slides. Depending on your Print settings, you can also print the slide notes along with the slides. 

Step 1 − To locate the slide notes, set the view in Normal mode. 

Step 2 − The Slide Notes section is indicated by "Click to add notes". 

Step 3 − You can click on the top border and drag the section to increase its size to 

   make it easier to type. 

Step 4 − Type your text in this section as slide notes. 

You can only use bullets, numbering and alignment functions in the Slide Notes section. All 

other functions can be selected, but can be applied only to the selected slide, not the notes. 

Slide notes can be printed from the print menu under the Backstage view. From the Print Layout option, 

select Notes Pages or 3 Slides. Notes Pages will print a single slide with the slide notes below it. The 3 

Slides will print all three slides with notes on the right side. 
 

5. Fundamentals of Internet 
5.1 Networking Concepts 



A network can be defined as a group of computers and other devices connected in some ways so as 

to be able to exchange data.-Each of the devices on the network can be thought of as a node; each 

node has a unique address.-Addresses are numeric quantities that are easy for computers to work 

with, but not for humans to remember. Example: 204.160.241.98-Some networks also provide names 

that humans can more easily remember than numbers. Example: www.javasoft.com, corresponding 

to the above numeric address 

Addressing Internet address Consists of 4 bytes separated by periodsExample:136.102.233.49-The R 

first bytes (R= 1,2,3) correspond to the network address;-The remaining H bytes (H = 3,2,1) are used 

for the host machine. Inter NIC Register: organization in charge of the allocation of the address ranges 

corresponding to networks.  

Criteria considered: 

 Geographical area (country) 

 Organization,  

 Enterprise 

 Department 

 Host.  

 

Domain Name System (DNS)-Mnemonic textual addresses are provided to facilitate the 

manipulation of internet addresses. DNS servers are responsible for translating mnemonic textual 

Internet addresses into hard numeric Internet addresses. 

4Ports-An IP address identifies a host machine on the Internet.-An IP port will identify a specific 

application running on an Internet host machine. -A port is identified by a number, the port number. 

-The number of ports is not functionally limited, in contrast to serial communications where only 4 

ports are allowed.-There are some port numbers which are dedicated for specific applications. 

Data Transmission-In modern networks, data are transferred using packet switching.-Messages are 

broken into units called packets, and sent from one computer to the other. -At the destination, data 

are extracted from one or more packets and used to reconstruct the original message.-Each packet has 

a maximum size, and consists of a header and a data area. -The header contains the addresses of the 

source and destination computers and sequencing information necessary to reassemble the message 

at the destination. 

 

Types of Networks:  
There are two principle kinds of networks:  

Wide Area Networks (WANs) and Local Area Networks (LANs). 

WANs 

 Cover cities, countries, and continents. 

 Based on packet switching technology 

 Examples of WAN technology: Asynchronous Transfer Mode (ATM),Integrated Services 

Digital Network (ISDN) 

LANs 

 Cover buildings or a set of closely related buildings.  

 Examples of LAN : Ethernet, Token Ring, and Fiber Distributed Data Interconnect (FDDI).  

Ethernet LANs: based on a bus topology and broadcast communication  

Token ring LANs: based on ring topology  

FDDI LANs: use optical fibers and an improved token ring mechanism based on two rings flowing 

in opposite directions. 

According to the protocols involved, networks interconnection is achieved using one or several of the 

following devices: 

 Bridge: a computer or device that links two similar LANs based on the same protocol. 

 Router: a communication computer that connects different types of networks using different 

  protocols. 

 B-router or Bridge/Router: a single device that combines both the functions of bridge and 

  router. 

 Gateway: a network device that connects two different systems, using direct and systematic 



                translation between protocols. 

 

5.2 Internet and its Services 

Internet is defined as an Information super Highway, to access information over the web. However, 

it can be defined in many ways as follows: 

 Internet is a world-wide global system of interconnected computer networks. 

 Internet uses the standard Internet Protocol (TCP/IP). 

 Every computer in internet is identified by a unique IP address. 

 IP Address is a unique set of numbers (such as 110.22.33.114) which identifies a computer 

location. 

 A special computer DNS (Domain Name Server) is used to give name to the IP Address so 

that user can locate a computer by a name. 

 For example, a DNS server will resolve a name http://www.tutorialspoint.com to a 

particular IP address to uniquely identify the computer on which this website is hosted. 

 Internet is accessible to every user all over the world. 

Evolution 

The concept of Internet was originated in 1969 and has undergone several technological & 

Infrastructural changes as discussed below: The origin of Internet devised from the concept of 

Advanced Research Project Agency Network (ARPANET). ARPANET was developed by United 

States Department of Defense. Basic purpose of ARPANET was to provide communication among 

the various bodies of government. Initially, there were only four nodes, formally called Hosts. In 

1972, the ARPANET spread over the globe with 23 nodes located at different countries and thus 

became known as Internet. By the time, with invention of new technologies such as TCP/IP 

protocols, DNS, WWW, browsers, scripting languages etc., Internet provided a medium to publish 

and access information over the web. 

Internet Services allows us to access huge amount of information such as text, graphics, sound and 

software over the internet. Following diagram shows the four different categories of Internet Services. 

ElectronicMail 
Used to send electronic message over the internet. 

Telnet 
Used to log on to a remote computer that is attached to internet. 

Newsgroup 
Offers a forum for people to discuss topics of common interests. 

Internet Relay Chat (IRC) 
Allows the people from all over the world to communicate in real time. 

Mailing Lists 
Used to organize group of internet users to share common information through e-mail. 

Internet Telephony (VoIP) 
Allows the internet users to talk across internet to any PC equipped to receive the call. 

Instant Messaging 
Offers real time chat between individuals and group of people. Eg. Yahoo messenger, MSN 

messenger. 

Web Services 

Web services allow exchange of information between applications on the web. Using web services, 

applications can easily interact with each other. 



World Wide Web (WWW) 

WWW is also known as W3. It offers a way to access documents spread over the several servers over 

the internet. These documents may contain texts, graphics, audio, video, hyperlinks. The hyperlinks 

allow the users to navigate between the documents. 

 

5.3 Browsers 

Web Browser 

Web Browser is an application software that allows us to view and explore information on the web. 

User can request for any web page by just entering a URL into address bar. 

Web browser can show text, audio, video, animation and more. It is the responsibility of a web 

browser to interpret text and commands contained in the web page. 

Earlier the web browsers were text-based while now a days graphical-based or voice-based web 

browsers are also available. Following are the most common web browser available today: 

Browser Vendor 

Internet Explorer Microsoft 

Google Chrome Google 

Mozilla Firefox Mozilla 

Netscape Navigator Netscape Communications Corp. 

Opera Opera Software 

Safari Apple 

Sea Monkey Mozilla Foundation 

K-meleon K-meleon 

Architecture 

There are a lot of web browser available in the market. All of them interpret and display information 

on the screen however their capabilities and structure varies depending upon implementation. But the 

most basic component that all web browser must exhibit are listed below: 

 Controller/Dispatcher 

 Interpreter 

 Client Programs 

Controller works as a control unit in CPU. It takes input from the keyboard or mouse, interpret it 

and make other services to work on the basis of input it receives. 

Interpreter receives the information from the controller and execute the instruction line by line. 

Some interpreter are mandatory while some are optional For example, HTML interpreter program is 

mandatory and java interpreter is optional. 

Client Program describes the specific protocol that will be used to access a particular service.  

Starting Internet Explorer 
Internet explorer is a web browser developed by Microsoft. It is installed by default with the windows 

operating system howerver, it can be downloaded and be upgraded. 



To start internet explorer, follow the following steps: 

 Go to Start button and click Internet Explorer. 

 

Accessing Web Page 

Accessing web page is very simple. Just enter the URL in the address bar  

Navigation 

A web page may contain hyperlinks. When we click on these links other web page is opened. These 

hyperlinks can be in form of text or image. When we take the mouse over an hyperlink, pointer change 

its shape to hand. 

Saving Webpage 

You can save web page to use in future. In order to save a webpage, follow the steps given below: 

 Click File > Save As. Save Webpage dialog box appears. 

 Choose the location where you want to save your webpage from save in: list box. Then choose 

the folder where you want to save the webpage. 

 Specify the file name in the File name box. 

 Select the type from Save as type list box. 

o Webpage, complete 

o Web Archive 

o Webpage HTML only 

o Text File 

 From the encoding list box, choose the character set which will be used with your webpage. 

By default, Western European is selected. 

 Click save button and the webpage is saved. 

 

 

 

5.4 Search Engines 

Search Engine refers to a huge database of internet resources such as web pages, newsgroups, 

programs, images etc. It helps to locate information on World Wide Web. 



User can search for any information by passing query in form of keywords or phrase. It then searches 

for relevant information in its database and return to the user. 

Search Engine Components 

Generally there are three basic components of a search engine as listed below: 

1. Web Crawler 

2. Database 

3. Search Interfaces 

Web crawler 
It is also known as spider or bots. It is a software component that traverses the web to gather 

information. 

Database 
All the information on the web is stored in database. It consists of huge web resources. 

Search Interfaces 
This component is an interface between user and the database. It helps the user to search through the 

database. 

Search Engine Working 

Web crawler, database and the search interface are the major component of a search engine that 

actually makes search engine to work. Search engines make use of Boolean expression AND, OR, 

NOT to restrict and widen the results of a search. Following are the steps that are performed by the 

search engine: 

 The search engine looks for the keyword in the index for predefined database instead of going 

directly to the web to search for the keyword. 

 It then uses software to search for the information in the database. This software component 

is known as web crawler.  

 Once web crawler finds the pages, the search engine then shows the relevant web pages as a 

result. These retrieved web pages generally include title of page, size of text portion, first 

several sentences etc. 

These search criteria may vary from one search engine to the other. The retrieved information is 

ranked according to various factors such as frequency of keywords, relevancy of information, links 

etc. 

 User can click on any of the search results to open it. 

Architecture 
The search engine architecture comprises of the three basic layers listed below: 

 Content collection and refinement. 

 Search core 

 User and application interfaces 



 
Search Engine Processing 
 

Indexing Process 
Indexing process comprises of the following three tasks: 

 Text acquisition 

 Text transformation 

 Index creation 

Text acquisition 
It identifies and stores documents for indexing. 

Text Transformation 
It transforms document into index terms or features. 

Index Creation 
It takes index terms created by text transformations and create data structures to suport fast searching. 

Query Process 
Query process comprises of the following three tasks: 

 User interaction 

 Ranking 

 Evaluation 

User interaction 
It supports creation and refinement of user query and displays the results. 

 

Ranking 
It uses query and indexes to create ranked list of documents. 

 

Evaluation 
It monitors and measures the effectiveness and efficiency. It is done offline. 

Examples 

Following are the several search engines available today: 

 

 



Search 

Engine 
Description 

Google It was originally called BackRub. It is the most popular search engine globally. 

Bing 
It was launched in 2009 by Microsoft. It is the latest web-based search engine that 

also delivers Yahoo’s results. 

Ask 
It was launched in 1996 and was originally known as Ask Jeeves. It includes support 

for match, dictionary, and conversation question. 

AltaVista 
It was launched by Digital Equipment Corporation in 1995. Since 2003, it is 

powered by Yahoo technology. 

AOL.Search It is powered by Google. 

LYCOS It is top 5 internet portal and 13th largest online property according to Media Matrix. 

Alexa It is subsidiary of Amazon and used for providing website traffic information. 

 

5.5 Email 

Email is a service which allows us to send the message in electronic mode over the internet. It offers 

an efficient, inexpensive and real time mean of distributing information among people. 

E-Mail Address 

Each user of email is assigned a unique name for his email account. This name is known as E-mail 

address. Different users can send and receive messages according to the e-mail address. 

E-mail is generally of the form username@domainname. For example, 

webmaster@tutorialspoint.com is an e-mail address where webmaster is username and 

tutorialspoint.com is domain name. 

 The username and the domain name are separated by @ (at) symbol.  

 E-mail addresses are not case sensitive. 

 Spaces are not allowed in e-mail address. 

 

E-mail Message Components 

E-mail message comprises of different components: E-mail Header, Greeting, Text, and Signature. 

These components are described in the following diagram: 



 

E-mail Header 
 

The first five lines of an E-mail message is called E-mail header. The header part comprises of 

following fields: 

 From 

 Date 

 To 

 Subject 

 CC 

 BCC 

From : The From field indicates the sender’s address i.e. who sent the e-mail. 

Date :  The Date field indicates the date when the e-mail was sent. 

To  :    The To field indicates the recipient’s address i.e. to whom the e-mail is sent. 

Subject : The Subject field indicates the purpose of e-mail. It should be precise and to the point. 

CC  :    CC stands for Carbon copy. It includes those recipient addresses whom we want to keep informed 

but not exactly the intended recipient. 

BCC :  BCC stands for Black Carbon Copy. It is used when we do not want one or more of the recipients to 

know that someone else was copied on the message. 

Greeting : Greeting is the opening of the actual message. Eg. Hi Sir or Hi Guys etc. 

Text : It represents the actual content of the message. 

Signature : This is the final part of an e-mail message. It includes Name of Sender, Address, and Contact 

Number. 

 

Advantages 
 

E-mail has proved to be powerful and reliable medium of communication. Here are the benefits of 

E-mail: 
 Reliable 

 Convenience 

 Speed 



 Inexpensive 

 Printable 

 Global 

 Generality 

 

Reliable 
Many of the mail systems notify the sender if e-mail message was undeliverable. 

 

Convenience 
There is no requirement of stationary and stamps. One does not have to go to post office. But all these 

things are not required for sending or receiving an mail. 

 

Speed 
E-mail is very fast. However, the speed also depends upon the underlying network. 

 

Inexpensive 
The cost of sending e-mail is very low. 

 

Printable 
It is easy to obtain a hardcopy of an e-mail. Also an electronic copy of an e-mail can also be saved 

for records. 

 

Global 
E-mail can be sent and received by a person sitting across the globe. 

 

Generality 
It is also possible to send graphics, programs and sounds with an e-mail. 

 

Disadvantages 
Apart from several benefits of E-mail, there also exists some disadvantages as discussed below: 

 Forgery 

 Overload 

 Misdirection 

 Junk 

 No response 

 

E-mail System 
E-mail system comprises of the following three components: 

 Mailer 

 Mail Server 

 Mailbox 

Mailer 
It is also called mail program, mail application or mail client. It allows us to manage, read and 

compose e-mail. 

 

Mail Server 
The function of mail server is to receive, store and deliver the email. It is must for mail servers to be 

Running all the time because if it crashes or is down, email can be lost. 

Mailboxes 
Mailbox is generally a folder that contains emails and information about them. 



Working of E-mail 
Email working follows the client server approach. In this client is the mailer i.e. the mail application 

or mail program and server is a device that manages emails. 

Following example will take you through the basic steps involved in sending and receiving emails 

and will give you a better understanding of working of email system: 

 Suppose person A wants to send an email message to person B.  

 Person A composes the messages using a mailer program i.e. mail client and then select Send 

option. 

 The message is routed to Simple Mail Transfer Protocol to person B’s mail server. 

 The mail server stores the email message on disk in an area designated for person B. 

The disk space area on mail server is called mail spool. 

 Now, suppose person B is running a POP client and knows how to communicate with B’s 

mail server. 

 It will periodically poll the POP server to check if any new email has arrived for B.As in this 

case, person B has sent an email for person B, so email is forwarded over the network to B’s 

PC. This is message is now stored on person B’s PC. 

 

The following diagram gives pictorial representation of the steps discussed above: 

 

Creating Email Account 

There are various email service provider available such as Gmail, hotmail, ymail, rediff mail etc. 

Here we will learn how to create an account using Gmail. 

 Open gmail.com and click create an account. 

 Now a form will appear. Fill your details here and click Next Step. 

 This step allows you to add your picture. If you don’t want to upload now, you can do it later. 

Click Next Step. 

 Now a welcome window appears. Click Continue to Gmail. 

 Wow!! You are done with creating your email account with Gmail. It’s that easy. Isn’t it? 

 Now you will see your Gmail account as shown in the following image: 

 

Key Points: 

 Gmail manages the mail into three categories namely Primary, Social and Promotions. 



 Compose option is given at the right to compose an email message. 

 Inbox, Starred, Sent mail, Drafts options are available on the left pane which allows you to 

keep track of your emails. 

Composing and Sending Email 
Before sending an email, we need to compose a message. When we are composing an email message, 

we specify the following things: 

 Sender’s address in To field 

 Cc (if required) 

 Bcc (if required) 

 Subject of email message 

 Text 

 Signature 

You should specify the correct email address; otherwise it will send an error back to the sender. 

Once you have specified all the above parameters, It’s time to send the email. The mailer program 

provides a Send button to send email, when you click Send, it is sent to the mail server and a message 

mail sent successfully is shown at the above. 

5.6 Using E-Mail 

Reading Email 

Every email program offers you an interface to access email messages. Like in Gmail, emails are 

stored under different tabs such as primary, social, and promotion. When you click one of tab, it 

displays a list of emails under that tab. 

In order to read an email, you just have to click on that email. Once you click a particular email, it 

gets opened. 

The opened email may have some file attached with it. The attachments are shown at the bottom of 

the opened email with an option called download attachment. 

Replying Email 

After reading an email, you may have to reply that email. To reply an email, click Reply option shown 

at the bottom of the opened email. 

Once you click on Reply, it will automatically copy the sender’s address in to the To field. Below the 

To field, there is a text box where you can type the message. 

Once you are done with entering message, click Send button. It’s that easy. Your email is sent. 

Forwarding Email 
It is also possible to send a copy of the message that you have received along with your own comments 

if you want. This can be done using forward button available in mail client software. 

The difference between replying and forwarding an email is that when you reply a message to a 

person who has send the mail but while forwarding you can send it to anyone. 

When you receive a forwarded message, the message is marked with a > character in front of each 

line and Subject: field is prefixed with Fw. 



 

Deleting Email 
If you don’t want to keep email into your inbox, you can delete it by simply selecting the message 

from the message list and clicking delete or pressing the appropriate command. 

Some mail clients offers the deleted mails to be stored in a folder called deleted items or trash from 

where you can recover a deleted email. 
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1. Who is the father of personal computer?        [     ] 

a. Edward Robert  

b. Allen Turing 

c. Charles Babbage 

d. None of these  

2. To record and produce sound in a computer system you need   [     ] 

a. Microphone 

b. Speakers 

c. Sound card 

d. All of above 

3. Which of the following is not a magnetic storage medium?   [     ] 

a. Floppy Disk 

b. Hard Disk 

c. Digital Versatile Disks 

d. Cassettes and Cartridges 

4. ALU stands for          [     ] 

a. Arithmetic and Logical Unit. 

b. Auxiliary and Logical Unit 

c. Arithmetic and Link Unit 

d. None of the above 

5. Which function in Excel tells how many numeric entries are there?  [ ] 
a. NUM 

b. COUNT 

c. SUM 

d. CHKNUM 

6. How many sheets are there, by default, when we create a new Excel file?   [ ]  
a. 1 

b. 3 

c. 5 

d. 6 

7. The temporary output of a computer system is called   [     ] 

a. Hardcopy output 

b. Softcopy output 

c. Computer Printout 

d. None of above 

8. Which device in microprocessor stores the data to be processed? [     ] 

a. ROM 

b. RAM 

c. Registers 

d. ALU 

9. A kind of memory chip that stores data and instructions permanently is[     ] 

a. ROM 



b. SRAM 

c. EEPROM 

d. RAM 

10. Which of the following ROM is most convenient to rewrite?  [     ] 

a. EPROM 

b. EEPROM 

c. EAPROM 

d. DRAM 

11. ___________is a volatile memory      [     ] 

a. ROM 

b. RAM 

c. EEPROM 

d. EPROM 
12. In which view Headers and Footers are visible    [     ] 

a. Normal View 

b. Page Layout View 

c. Print Layout View 

d. Draft View 

13. To cut the text we can press ________ in MS-Word.   [     ] 

a. Ctrl + V 

b. Ctrl + C 

c. Ctrl + X 

d. Ctrl + E 

14. To apply center alignment to a paragraph we can press    [     ] 

a. Ctrl + S 

b. Ctrl + C 

c. Ctrl + C + A 

d. Ctrl + E 

15. Which items are placed at the end of a document    [     ] 

a. Footer 

b. Foot Note 

c. End Note 

d. Header 

16. To copy the text we can press ________ in MS-Word.   [     ] 

a. Ctrl + V 

b. Ctrl + C 

c. Ctrl + A 

d. Ctrl + E 

17. We can insert a page number at __________ in MS-Word.  [     ] 

a. Header 

b. Footer 

c. Both A and B 

d. none 

18. Which one can be used as watermark in a word document   [     ] 

a. Text 

b. Image 

c. Both A and B 

d. None 

 

19. We can change the thickness of a line from ___     [    ] 

a. Line width 

b. Line Height 

c. Line Thick 

d. Line Style 

20. Color and pattern used to fill a closed shape is called    [    ] 

a. Shape 



b. WordArt 

c. Fill Style 

d. Fill Back 

21. What is the intersection of a column and a row on a worksheet called ? [    ] 

a. Column 

b. Value 

c. Address 

d. Cell 

22. What type of chart is useful for comparing values over categories?  [       ] 
a. Pie Chart 
b. Column Chart 

c. Line Chart 

d. Dot Graph 

23. Which one is not a Function in MS Excel ?     [ ] 
a. SUM 

b. AVG 

c. MAX 

d. MIN 

24. Functions in MS Excel must begin with ___     [ ] 
a. An () sign 

b. An Equal Sign 

c. A Plus Sign 

d. A > Sign 

25. In Excel, Columns are labelled as ___      [ ] 
a. A, B, C, etc 
b. 1,2,3 etc 
c. A1, A2, etc. 
d. $A$1, $A$2, etc. 

26. To undo an operation in MS-Word we can press     [     ] 

a. Ctrl + A 

b. Ctrl + B 

c. Ctrl + Z 

d. Ctrl + E 

 

27. The process of arrenging the items of a column in some sequence or order is 
known as :           [ ] 

a. Arrengin 

b. Autofill 

c. Sorting 

d. Filtering 

28. What type of chart is useful for comparing parts of a whole ?   [ ] 
a. Pie Chart 

b. Column Chart 

c. Line Chart 

d. Dot Graph 

29. What do you use to create a chart?       [ ] 

a. Pie Wizard 

b. Excel Wizard 

c. Data Wizard 

d. Chart Wizard 

30. How to Open a presentation in PowerPoint?    [ ] 

a. Ctrl + K 

b. Ctrl + O 

c. Ctrl+ A 

d. None of these 

31. How to create a new presentation in PowerPoint?   [ ] 



a. Ctrl + N 

b. Ctrl + M 

c. Ctrl+ S 

d. None of these 

32. How to save a presentation in PowerPoint?    [ ] 

a. Ctrl + N 

b. Ctrl + M 

c. Ctrl+ S 

d. None of these 

33. How to print a presentation in PowerPoint?    [ ] 
a. Ctrl+ P 

b. Ctrl+ O 

c. Ctrl+ S 

d. None of these 

34. How to go to next slide in PowerPoint?     [ ] 

a. Tab 

b. Next key arrow 

c. Spacebar 

d. None of these 

35. Which key is used for Help in PowerPoint?    [ ] 

a. F1 

b. F2 

c. F3 

d. None of These 

36. How to cut text in presentation in PowerPoint?    [ ] 
a. Ctrl+C 

b. Ctrl+X 

c. Ctrl+L 

d. None of These 

37. To end the Slide show in PowerPoint:     [ ] 

a. Esc 

b. End 

c. Delete 

d. None of these  

38. Which keys are used to find in PowerPoint?    [ ] 

a. Ctrl+I 

b. Ctrl+E 

c. Ctrl+F 

d. None of These 

39. To Justify the text in PowerPoint:      [ ] 

a. Ctrl+ L 

b. Ctrl+ E 

c. Ctrl + J 

d. None of these 

40. Which of these is the easiest way of communication?   [ ] 

a. E-mail 

b. Telephone 

c. Fax 

d. Letter 

41. Search engine are used to ________.     [ ] 

a. Search Videos 

b. Search Documents 

c. Software system that is designed to search for information on the World Wide Web 

d. All of these 

42. Search Engines are able to search ________ type of information. [ ] 

a. Documents 



b. Images 

c. Videos 

d. All of these 

43. Search Engines maintain heavy database of keywords and urls ! [ ] 

a. True 

b. False 

44. E-Mail address is made up of _____     [ ] 

a. Two parts 

b. Single part 

c. Three parts 

d. None of these 

45. Search engine which is most popular in India is    [ ] 

a. yahoo 

b. bing 

c. google 

d. baidu 

46. Computer understands only      [ ] 

a. Binary Language 

b. High level Language 

c. Assembly Language 

d. None of these 

47. The smallest unit of data in computer is _______________  [ ] 

a. Byte 

b. Nibble 

c. Bit 

d. KB 

48. The two basic types of memory in a computer are ________  [ ] 

a. Primary and major 

b. Primary and Secondary 

c. Minor and Major 

d. Main and virtual 
49.  Google is a search engine       [ ] 

a. True 

b. False 

50. A CPU contains        [     ] 

a. a card reader and a printing device 

b. an analytical engine and a control unit 

c. a control unit and an arithmetic logic unit 

d. an arithmetic logic unit and a card reader 
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